Query About Snapd package of Snap Store and Firefox and chromium wont install on Debian 11

Hy Snap craft community, i wanted to ask what is the use,purpose and application of the latest Snapd available from Snpa Store since it doesnt seem to have any use ? I Tried Installing Chromium and Firefox from SnapStore,it gets downloaded but wont install saying the following : {Mount snap “firefox” (2211) (snap “firefox” assumes unsupported features: snapd2.54 (try to update snapd and refresh the core snap))} The Snapd Available in Debian 11 is 2.49, to resolve this i installed Snapd from SnapStore of version 2.56 but it doesnt seem to have any affect.

So i want to ask about the use of the Snapd available from SnapStore and also a workaround for the following problem.

1 Like

Odd… installing snapd through itself should update snap. You can verify what version of snap and snapd are running with the command snap --version

I don’t have a plain Debian machine available to test with, but on my Chromebook the default Debian container in Crostini has the snapd snap installed and has snap version 2.57.6 running. It’s possible that something’s preventing a restart of snapd, in which case the easiest thing to do would probably be to reboot your machine. (If you don’t want to reboot, you can try restarting snapd with systemctl and figure out what might be causing it to fail to restart.)

1 Like

The Snapd from Snap has literally no effect/affect, here is the output of snap --version :

  • snap --version
  • snap 2.49-1+deb11u2
  • snapd 2.49-1+deb11u2
  • series 16
  • peppermint -
  • kernel 5.10.0-20-amd64

Even setting up snapd/snap was difficult i had to add snap bin path in visudo list and $PATH to get snaps working…

This output is after sudo systemctl restart snapd, also rebooted zillion of times***

1 Like

I tried to reproduce this with a Debian cloud image:

$ multipass launch -c 2 -n debian https://cloud.debian.org/images/cloud/bullseye/latest/debian-11-generic-amd64.qcow2

From there I ran:

$ sudo apt update
$ sudo apt install snapd

and I did indeed get:

$ snap --version
snap    2.49-1+deb11u2
snapd   2.49-1+deb11u2
series  16
debian  11
kernel  5.10.0-20-amd64

When I tried to install Firefox, it automatically updated snapd and then installed Firefox 108:

$ sudo snap install firefox
2022-12-28T23:12:39-05:00 INFO Waiting for automatic snapd restart...
firefox 108.0.1-1 from Mozilla✓ installed
$ snap --version
snap    2.57.6
snapd   2.57.6
series  16
debian  11
kernel  5.10.0-20-amd64

However, I noticed from the output of snap --version on your machine that you’re using Peppermint OS. I don’t have an easy way to test Peppermint specifically (though I’ve got a VM installing at least partially out of curiosity). Can you provide more details about the particular configuration of Peppermint you have? (e.g. the contents of /etc/os-release, any major system configuration changes you’ve made, etc.)

Well i dont think peppermint community makes much change in debian base,they simply provide some themes and tools,still here is the output of /etc/os-release :

uname -a: Linux sam-hpnotebook 5.10.0-20-amd64 #1 SMP Debian 5.10.158-2 (2022-12-13) x86_64 GNU/Linux

uname -v: #1 SMP Debian 5.10.158-2 (2022-12-13)

inxi -S:

  • Host: sam-hpnotebook Kernel: 5.10.0-20-amd64 arch: x86_64 bits: 64
  • Desktop: Xfce v: 4.16.0 Distro: Peppermint OS*

**I think i agree that something is definitely wrong with peppermint os as i previously mentioned that upon installation and a successful restart of snapd, it bugged me with the output of snap/bin not being in path then i fixed it with adding snap/bin in my visudo path list and $PATH, this is the only major change i did to snapd…

Hmmm well the bad news is that I tried twice (with freshly downloaded ISOs) and couldn’t get Peppermint OS to install in a VM, so I can’t replicate the issue.

I will say that on Debian my sudoers secure_path doesn’t get /snap/bin (I would guess that Ubuntu changes the secure_path to include that?) However, that didn’t affect running snap for me (just other apps in /snap/bin), as it appears the snap executable in /usr/bin is smart enough to grab the version in /snap/bin before proceeding. Additionally, the snapd package on Debian includes a /etc/profile.d/apps-bin-path.sh file which appends /snap/bin to regular users’ paths, so it should only be your sudoers secure_path that needed modifying, unless Peppermint made a change to the package. (They don’t appear to have from what I can see though).

The only other thing I can think of after finding the related thread on the PeppermintOS forum is to check something that should be really obvious… Did you by chance install from one of the Devuan-based images rather than the Debian-based ones? I’m guessing not since systemctl seemed to work fine for you (and if you had you’d probably have needed to manually download the deb file of snapd since it’s not in the Devuan repos), but I’m basically otherwise out of ideas for what could be causing this. Sorry :-/

Any other Snapd Developer ?? who can look out in this as Peppermint community has said they arent responsible check out with the package maintainer or creator…

Shifted to Lubuntu, Problem solved, snap and snapd are best supported in Ubuntu only from my experience