Puppy linux bionic 32bit

Could someone tell how to make snapd work on puppy linux? I installed systemd because I read that it is necessary but I get an error message that says it cannot connect to server when I try to find a snap. It seems that if I could configure the server it would work.

Is snapd.service running? Maybe you need to systemctl start snapd (and if that works, maybe systemctl enable snapd so it starts on boot).

I tried those things but get an error message that says systemd does not init system so it will not work. Puppy runs on busybox command line. Is there a busybox command to start and enable snapd.service?

You can just run snapd (as root), maybe?

Puppy linux is automatically root. If I simply write in snapd.service it replies that there is no such command the same when I type in just snapd. Right now I am having a problem with internet. I must solve that before I can go further.

Hello I am back.
Snapd gives me this.

bash: snapd: command not found
script snapd.service gives me this.

script snapd.service
Script started, file is snapd.service

enable snapd.service gives me this.
enable snapd.service
bash: enable: snapd.service: not a shell builtin

and snap install snap-store gives me this
snap install snap-store
error: cannot communicate with server: Post http://localhost/v2/snaps/snap-store: dial unix /run/snapd.socket: connect: no such file or directory

What am I doing wrong or what should I do that I am not doing

I’m not sure why you did any of those things. Did you try systemctl start snapd?

Thanks for your help. I gave up on snapd. I got the program I wanted working on flatpak. As for system ctrl, it gave me an error message to the effect that systemd could not do the job because it was not system init.