Pulseaudio snap does not have network plug


#1

I’d like to enable the RTP server on the pulseaudio snap within ubuntu core 18

sudo pactl load-module module-rtp-recv sap_address=192.168.0.1

but I receive the following error

Oct 01 00:26:24 localhost audit[962]: AVC apparmor="DENIED" operation="create" profile="snap.pulseaudio.pulseaudio" pid=962 comm="pulseaudio" family="inet" sock_type="dgram" protocol=0 requested_mask="create" denied_mask="create"
Oct 01 00:26:24 localhost pulseaudio.pulseaudio[810]: E: [pulseaudio] module-rtp-recv.c: Failed to create socket: Permission denied
Oct 01 00:26:24 localhost pulseaudio.pulseaudio[810]: E: [pulseaudio] module.c: Failed to load module "module-rtp-recv" (argument: "sap_address=192.168.0.1"): initialization failed.
Oct 01 00:26:24 localhost kernel: audit: type=1400 audit(1569889584.622:111): apparmor="DENIED" operation="create" profile="snap.pulseaudio.pulseaudio" pid=962 comm="pulseaudio" family="inet" sock_type="dgram" protocol=0 requested_mask="create" denied_mask="create"

I tried to connect the appropriate interface/plug with snap connect pulseaudio:network-bind , but it didn’t work.

Looking at the source code, it looks like we might just be missing the network-bind plug?

https://git.launchpad.net/~snappy-hwe-team/snappy-hwe-snaps/+git/pulseaudio/tree/snapcraft.yaml

Any hints as to how I could get this working?

Thanks!!


#2

i have created:

https://code.launchpad.net/~ogra/snappy-hwe-snaps/+git/pulseaudio/+merge/373452

now waiting for a review … it should land soon in master (and the edge channel)


#3

Thanks Orga, that’s wonderful.

Is there a way to see when it gets onto the edge channel? I tried snap refresh pulseaudio --edge and although a new version was installed, it doesn’t seem to be this one.

Thanks again!


#4

there are various issues that I found along the way adding this one-liner … the snap has not been updated to be built by a newer snapcraft, CI tests have not been kept up to date etc … so there is some more work involved … i’ll ping here in the thread once there is something in the edge channel …

since @ondra did a lot of these fixes above already in a personal snap (which isnt in the public store atm) you can in the interim just download a snap from
https://launchpad.net/~ondrak/+snap/pulseaudio-stable-xenial
(just click the “Successfully Built” link for the architecture you want) and install that with the --dangerous option to snap install … the one that eventually lands in the store will be the same thing …


#5

Thank you, that’s a really helpful work around for now.


#6

Hi @ogra

I was able to finish this part of our project thanks to the temporary solution you provided. It was very helpful.

Do you have any estimate for when the fix might make it onto edge and then into production? We’re building our own device and are trying to create a timeline of the remaining work. This is a dependency for our final deployment, and any estimates you could give us would be tremendously helpful.

Thanks very much!

Craig


#7

depending on my other work duties i plan to get this landed this week …


#8

@craigulliott if by any chance you are running Ubuntu Core 18, you probably want to use this version:
https://launchpad.net/~ondrak/+snap/pulseaudio-stable-bionic
it’s same functionality, just based on Bionic and with Core18 base