Problems with installing spotify / slack


#1

I have this linux version:
Linux version 4.14.21-1-MANJARO (builduser@development) (gcc version 7.3.0 (GCC))
I used this commands to install snap:
sudo pacman -Sy snapd
sudo systemctl enable --now snapd.socket

Then installed Spotify with this command:
snap install spotify from the website: https://www.spotify.com/nl/download/linux/

I got this error:

- Mount snap "core" (4110) ([start var-lib-snapd-snap-core-4110.mount] failed with exit status 1: Job for var-lib-snapd-snap-core-4110.mount failed.
See "systemctl status var-lib-snapd-snap-core-4110.mount" and "journalctl -xe" for details.
)

So I runned this command systemctl status var-lib-snapd-snap-core-4110.mount
and got this back:

● var-lib-snapd-snap-core-4110.mount - Mount unit for core
   Loaded: loaded (/etc/systemd/system/var-lib-snapd-snap-core-4110.mount; enabled; vendor preset: disabled)
   Active: failed (Result: exit-code) since Fri 2018-03-09 17:13:50 CET; 17min ago
    Where: /var/lib/snapd/snap/core/4110
     What: /var/lib/snapd/snaps/core_4110.snap
  Process: 9407 ExecMount=/usr/bin/mount /var/lib/snapd/snaps/core_4110.snap /var/lib/snapd/snap/core/4110 -t squashfs -o nodev,ro,x-gdu.hide (code=exited, status=1/FAILURE)

mrt 09 17:13:50 steven-pc systemd[1]: Mounting Mount unit for core...
mrt 09 17:13:50 steven-pc mount[9407]: mount: /var/lib/snapd/snap/core/4110: mount failed: Actie is niet toegestaan.
mrt 09 17:13:50 steven-pc systemd[1]: var-lib-snapd-snap-core-4110.mount: Mount process exited, code=exited status=1
mrt 09 17:13:50 steven-pc systemd[1]: var-lib-snapd-snap-core-4110.mount: Failed with result 'exit-code'.
mrt 09 17:13:50 steven-pc systemd[1]: Failed to mount Mount unit for core.

Dit I did something wrong?


#2

does your system have support for squashfs? maybe you need a kernel module?


#3

I am a bit noob, I really don’t know what you mean? Is there a way to check that?


#4

yes, there is. The easiest way is probably this:

  1. Download this very small squashfs.
  2. Open a terminal in the directory that holds that file.
  3. In the terminal, run this: sudo mount bare.squashfs /mnt && ( echo YES; sudo umount /mnt ) || echo NO

if it echoes YES, it worked. If not, you need to get the modules for squashfs.

Maybe @Conan_Kudo can give some more focused advice, though (am I right in remembering you had something to do with manjaro?).


#5

Nope. That’s @mborzecki through his Arch work. @philm manages snapd for Manjaro.


#6

I’ve just tried installing the Spotify snap in my Manjaro VM, no issues so far.

Make sure that you reboot after installing the new kernel. Snaps use squashfs which needs a kernel module to work. The module is inserted automatically for the running kernel. This means that you need to be running the same kernel as is installed by pacman. In this case, I see that the Manjaro installation I have is running 4.14.24 kernel, you reported that you have 4.14.21. If the kernel was upgraded on your machine, but you did not reboot, any attempts to load squashfs modules (and hence mounts) will fail.

I would suggest to try snapd package from AUR as it gets regular updates. In fact the last update to 2.31.2 was just today.