Problems with Chromium (80.0.3987.100)

Yesterday chromium started playing up on me. It wouldn’t allow text entry in any box, and if my cursor had selected any text box for entry, commands like ^N to open a new tab wouldn’t work either. Thanks to some help from @oerheks on IRC, I’ve got that issue resolved (removing cache, then most of my config folder; everything deleted except for my history & tabs was my intention).

After this it started pretty fresh & appeared good, so I re-added my wanted extensions & used it normally. In trying to moderate some wallpaper [comp.] entries I tried downloading some entries/files and it just crashes each time (downloading files from

It’s not a global issue; as I went to another box & completed what I want to do (other box is almost identical hardware though a almost fresh QA-test install it won’t have all my history/bloat/configs).

There also aren’t any crash files in /var/crash/, but where else can details/clues be found for snaps that crash. Is there doco on where I need to read/learn, or any advice would be appreciated. (or should this be posted on the call for testing: chromium still?)

Reported on Launchpad:

gnome-calculator also ignores keyboard input.

Same here on Firefox Snap, Discord, etc.

As mentioned in those bug reports, the underlying problem is that new versions of IBus (an input method framework) change the location of the socket applications use to communicate with ibus-daemon. The AppArmor rules in the policies snapd generates for snaps allow access to the old socket location but not the new location.

The recent IBus update in 20.04 included a backport of this change, which is why you are seeing the problem now.

@jdstrand has put together a fix for the problem here:

It has been merged to master, and should make its way into a 2.43 maintenance release.

1 Like

There is a new version of snapd currently in focal-proposed with the above fix:

When the update is promoted from proposed, you should receive it automatically. Alternatively you can try installing it directly. I wouldn’t recommend enabling the proposed repository outright, since the packages there have undergone less testing.


@jamesh I have

guiverc@d960-ubu2:~$ apt-cache policy snapd
Installed: 2.43.3+git1.8109f8
Candidate: 2.43.3+git1.8109f8

On loading chromium, the moment I try and upload a picture (tried or download a file (tried it just crashes.

I did a apt full-upgrade earlier this morning, and I tried (killed snapd & it auto-restarted) test. Now hours later I’ve rebooted and chromium still crashes on any attempt to upload photo, or download of file.

Can you provide the output of the snap version command? It is possible that snapd is re-execing to the version in the core snap, which doesn’t include the fix.

guiverc@d960-ubu2:~$ snap version
snap 2.43.3+git1.8109f8
snapd 2.43.3+git1.8109f8
series 16
ubuntu 20.04
kernel 5.4.0-14-generic

I’m also seeing this second issue on a fully updated Ubuntu 20.04.
Snap details the same as above.
Bug report: #1863801.

1 Like