Problem with spotify. Flavor select no such file or directory


#1

Good morning people.

I installed spotify with a snap. I am principiant at this.

After install spotify running comando “snap install spotify” i tried running spotify without success.

I search folder where snap store the files and enter folder /snap/spotify/current/bin tried run ./desktop-launch where get the next error “./desktop-launch: line 368: /flavor-select: No such file or directory”.

The file flavor-select exists in the /snap/spotify/current path, but not is a folder.

Wait for your help, thanks! Sorry for my bad english.


#2

Try snap run spotify.

If you just installed snapd then you must log out for the PATH and desktop integration to start to work. Good luck!


#3

Thanks, this solution work for me.

Only one answer more before close thread, where snap stores the bins? Why no stores the bins in /usr/bin?


#4

The executables are under /snap/bin or /var/lib/snapd/snap/bin, depending on the distro you’re running. The proper path is automatically added to your $PATH by a script that the snapd package drops into /etc/profile.d. Can you verify if one of those paths is in your $PATH?

If this is happening right after snapd was installed, then you may need to logout/login again, or start a new login shell (bash -l in the terminal) and try to run spotify from there.