Problem with snapd and snaps on Solus 3.9999


I have big issues with snap since lasts updates on Solus. When i reboot and try to launch snaps i have these messages :

cannot change profile for the next exec call: No such file or directory
snap-update-ns failed with code 1: No such file or directory

snap version :

snap 2.32.9
snapd 2.32.9
series 16
solus 3.9999
kernel 4.16.13-74.current

I talked with a snap dev on Solus IRC channel and it seems it is related to apparmor because when i use the command :

sudo apparmor_parser -r /var/lib/snapd/apparmor/profiles/*

i can start my snap.

I have another problem with wrong characters appearing on some snaps apps. You can see screenshots on my G+ post here :é/posts/ETuonD1RQXD

Another screenshot here :

PS : These problems appear with mattermost-desktop and gravit-designer snaps.

Thanks for your help.


1 Like

Thank you for reporting this issue.

We discussed this on IRC and after some debugging it looks like apparmor userspace systemd unit is not loading profiles from /var/lib/snapd/apparmor/profiles.

We have some features that may fix this in general and I was wondering if we should deploy the new snapd.apparmor.service across the stack (everywhere where appamor is enabled).

CC @jdstrand for ideas?

@ikey this looks lie a regression

@zyga-snapd - something needs to load them. If the normal apparmor service isn’t going to, then yes, snapd.apparmor.service would be the way to go.


@zyga-snapd just saw this happen now on two devices running core revision 5207
One is classic, one is UC16

@zyga-snapd seem related to layout, when I remove layouts from snap.yaml it works as expected.
At the same time I have added before same layout to the same snap and it was working fine, only when I did clean rebuild of the snap, it went south…

@zyga-snapd some logs collected here:

1 Like

openSUSE Tumbleweed users seem to find this thread. For them it’s useful to note that when they install or update snapd nowadays, they get the following guidance which when executed fixes the error message from this thread:

“On a Tumbleweed system you need to run: systemctl enable snapd.apparmor.service”

(also, remember to systemctl enable snapd.service too)

1 Like