Problem installing snap-proxy

I’m not able to successfully complete an installation of snap-proxy. I followed these instructions.

I tried setting up a LXC container. All steps until registration were OK. But then with the final registration step I’m getting:

Failed to register store:
Developer has not signed agreement.
error: 403 Client Error: FORBIDDEN for url:

It’s not clear to what agreement exactly it wants to be signed.

You need a snap developer account. Go to and sign in, you should be asked to review and accept developer terms of service. That should get the registration to work.

Thanks for the reply.

Somehow some magic happened, because after trying to register the snap proxy a few more times, it suddenly succeeded. All I did was to first register to this forum, to ask for help. Maybe that did the trick.

Anyway. It would help others to document this at the registration page. Or at the troubleshoot page.

It did not - forum login is entirely disconnected and independent of both Ubuntu SSO and the snap dashboard.

Im still glad to hear it worked :slight_smile:

  • Daniel