Problem getting audio connected

I’m making an app , my_audio_dsp_app, that does DSP on audio input and makes audio output.

When I (make a snap) and run the app then no audio I/O is available to my_audio_dsp_app.

This is the snapcraft.yaml file used to create the snap.

As you can see audio plugs are specified:

  - alsa
  - audio-playback
  - audio-record
  - pulseaudio

And when the snap is installed I run these commands:

eigil@stendell-wsl:~/Projects/JuceProjs/my_audio_dsp_app$ sudo snap connect my_audio_dsp_app:audio-record :audio-record
eigil@stendell-wsl:~/Projects/JuceProjs/my_audio_dsp_app$ sudo snap connect my_audio_dsp_app:pulseaudio :pulseaudio
eigil@stendell-wsl:~/Projects/JuceProjs/my_audio_dsp_app$ snap connections my_audio_dsp_app
Interface                 Plug                            Slot                             Notes
alsa                      my_audio_dsp_app:alsa             :alsa                            manual
audio-playback            my_audio_dsp_app:audio-playback   :audio-playback                  -
audio-record              my_audio_dsp_app:audio-record     :audio-record                    manual
content[gnome-3-28-1804]  my_audio_dsp_app:gnome-3-28-1804  gnome-3-28-1804:gnome-3-28-1804  -
content[gtk-3-themes]     my_audio_dsp_app:gtk-3-themes     gtk-common-themes:gtk-3-themes   -
content[icon-themes]      my_audio_dsp_app:icon-themes      gtk-common-themes:icon-themes    -
content[sound-themes]     my_audio_dsp_app:sound-themes     gtk-common-themes:sound-themes   -
desktop                   my_audio_dsp_app:desktop          :desktop                         -
desktop-legacy            my_audio_dsp_app:desktop-legacy   :desktop-legacy                  -
gsettings                 my_audio_dsp_app:gsettings        :gsettings                       -
opengl                    my_audio_dsp_app:opengl           :opengl                          -
pulseaudio                my_audio_dsp_app:pulseaudio       :pulseaudio                      manual
wayland                   my_audio_dsp_app:wayland          :wayland                         -
x11                       my_audio_dsp_app:x11              :x11                             -

But no audio devices are presented to the my_audio_dsp_app and the my_audio_dsp_app can’t find any Audio devices.

I tried this snapcraft.yaml also. (I found it here)

Then the my_audio_dsp_app can find the alsa but no sound gets through from/to my_audio_dsp_app in the snap.

What am I missing / doing wrong ?

When my_audio_dsp_app is run outside snap these audio devices are available: AvailableInputsNoSnap

PulseAudio sound server normally works best.

– Eigil