Plex Media Server currently not available after reboot

Hi! So I have this recurring problem that comes once in a while but not every time…

After a power failure or a reboot of my server, the Plex snap starts and seems to be working. But when trying to access Plex via browser I get a error: “PLEXSERVER is currently unavailable Verify you have a network connection and that the server is online, or see our tips for further assistance.”

I’ve tried restarting plex with “sudo snap restart plexmediaserver” and it seems to work and gives no errors, but the server is still unavailable. So I tried “sudo snap stop plexmediaserver” witch seems to work and gives no error or entry in log. But when i try to do a “sudo snap start plexmediaserver” witch seems to work, but in the log it gives a few errors:

    2022-02-12T16:55:54+01:00 plexmediaserver.plexmediaserver[38122]: ERROR: object '/usr/local/lib/' from /etc/ cannot be preloaded (cannot open shared object file): ignored.
    2022-02-12T16:55:54+01:00 plexmediaserver.plexmediaserver[38124]: Plex Media Server is already running. Will not start...
    2022-02-12T16:55:54+01:00 systemd[1]: snap.plexmediaserver.plexmediaserver.service: Main process exited, code=exited, status=1/FAILURE
    2022-02-12T16:55:54+01:00 systemd[1]: snap.plexmediaserver.plexmediaserver.service: Failed with result 'exit-code'.

So it’s still running, despite the stop command it seems. How to force a quit and make it restart properly?
What I have been doing to get it back up and running is a couple of reboots, sometimes it works at first try others I have to give it a few reboots to get it back.

This is on Linux Mint btw.

I’ve also tried “sudo services snapd restart” without getting Plex to restart. It still gives the same error.

I did a reboot, and it’s back up and running. It might have something to do with this:

But I did not get around to test it this time. Leaving link so others might try it later, or for myself when this happens again.