Pinta snap not visible in Ubuntu Software

Hi,
on Ubuntu 20.04 I have installed Pinta snap from terminal and it is working excellent without a problem. But when I check snap package in Ubuntu Software it is displayed as not installed. Any idea why Ubuntu Software does not recognizes Pinta snap to be installed?
Thanks

On the left, it shows you a snap called pinta-james-carroll, while on the right it appears you’re browsing a snap called pinta.

It looks like this was an example of the developer wanting to rename the snap, which snapd does not natively support. So you’ve ended up with an orphaned snap installed.

You could try installing the new snap, and then remove the old one if you’re happy with the new one.

1 Like

I reuploaded the snap after getting permission for name proper and adding upstream as a collaborator. It was very popular package and having evaluated the options I thought it best to rip the bandaid once to encourage people to migrate to the newer package over time. By the time 1.8 arrives, it’s likely most the users of the old package will have uninstalled, and there’ll be a note in the release notes documenting the change too. The current trajectory is looking healthy there.

1 Like

In other snaps (e.g. irccloud-desktop ) we added a wrapper which “punches” the user in the face with a dialog, “encouraging” them to migrate to the new snap. It works rather well.

2 Likes

The wrapper nagging was considered and will be used for another snap I’m migrating the name for. However I don’t think it was necessary for Pinta, the security concerns are minimal, the user experience is almost entirely unaffected (OP noticing the discrepency in the snap-store GUI is effectively the biggest issue, and the snap-store gui still allows removals and modifying interfaces) and updates for Pinta are on the order of months/years (1.6 to 1.7 was 5 years!, and 1.8 is still a few months minimum away yet). The snap is still newer than Ubuntu 21.04’s apt equivilent.

In 3 weeks, the older package has lost about 2000 users (15000 to go!) and the newer package has gone up by about the same, OP is the first person as far as I can tell to notice anything had even changed which is promising.

Meanwhile with my snap for Joplin, despite having less users I have decided to keep pushing updates to both package names because the security/privacy concern is higher, and being a note taking application with synchronisation between different platforms, worrying about compatibility with newer clients is also a concern. Eventually as users drop off I’ll take the nag approach there, but Pinta doesn’t have basically any of the same concerns.

Hopefully one day snapcraft itself can alleviate this process somewhat, because IMO issues relating to package names is one the biggest issues surrounding snaps and maintainers long term, and a better migration strategy where the package manager itself understands what’s going on would be great.

1 Like

I have noticed some inconsistency between my terminal and Ubuntu Software, because with Pinta I tried to open image file from USB drive and Pinta returned access error. I know I can use terminal to grant permissions, but the simplest way is to just go to Ubuntu Software and click on check box to enable “Read/write files on removable storage devices” permission. But to my surprise there was indicator that my beloved Pinta is not installed.

I have now solved the problem by uninstalling old name snap:
sudo snap remove pinta-james-carroll

and installed new name snap:
sudo snap install pinta

and now in Ubuntu Software everything is fine, I can see Pinta snap installed and I can set remote storate device permissions.


One additional thing I would like to discuss about Ubuntu Software is there are two Pinta’s displayed
one is 5 years old Pinta 1.6 apt package (pretty buggy) and the second is Pinta 1.7 snap package (released few months ago and regularly updated with new fixes in this branch by magnificent James-Carroll). Reading comments on both of them and all of those problems are related to Pinta 1.6. Users commenting on this program are incorrectly typing comments in Pinta 1.7 snap with terrible problems they have with Pinta 1.6.


In my humble opinion Pinta 1.6 should be removed from Ubuntu 20.04 repository in Ubuntu Software and all comments at Pinta 1.7 deleted, because they are referencing the old version of program. This is probably not snap related and snapcraft.io related problem. But you see how can some software stores decreases program’s reputation.

1 Like

From what I remember testing, unlisted snaps would have appeared on the “installed” tab, but wouldn’t appear if you searched for it it in the explore tab, so I guess that is confusing but it isn’t entirely inaccessible via GUI.

I do share the concerns with the ODRS service used for review, however speaking about how the service is implemented now and not how I’d like it to be, the damage is already done. ODRS cannot and does not want to tell the difference between different versions of Pinta, it cannot distinguish Focal’s Pinta, Bionics Pinta, the PPA’s Pinta, or Fedora’s Pinta. It can distinguish the snap, but merges snap reviews on a policy that the packaging shouldn’t matter, so users saying the snap doesn’t work probably don’t realise they’re actually reviewing both packages at the same time. In an extreme case, I actually have someone recommend against the Ubuntu package and recommend using the snap instead, indirectly giving the snap a 1* review :).

So if Pinta disappeared from the focal repo’s today and was added back later in better form, it’d still have all those bad reviews that are now entirely irrelevant, and given the problem is more widespread than just Ubuntu, there’s little to be gained without replacing ODRS or changing it substantially.

(For people less familiar with Pinta, the Mono dependency in 20.04 causes substantial stability issues and upgrading the Mono package results in a very stable Pinta experience even with the apt package.)