Pinta: Painting Made Simple

Pinta: Painting Made Simple

https://www.pinta-project.com/

source code https://github.com/PintaProject/Pinta

3 Likes

I have seen on Pinta’s bug tracker and on many forums users are having stability and freezing problems with latest Pinta 1.7 released few days back, see release notes: https://www.pinta-project.com/releases/1-7 and the main cause of it is Mono 6.10 should be installed. Installing latest stable Mono from PPA: https://www.mono-project.com/download/stable/ and Pinta is super stable.

The main problem is: every Ubuntu versions currently officially supported are having its own version of Mono and every Mono version installed as default on Ubuntu-s is outdated for Pinta 1.7. Snaps package would be perfect fit for fixing this kind of dependency hell problems. And Pinta is very nice simple image and drawing tool. Perfect fit for beginners and simple image editors.

How hard is it to create Pinta snap? It should probably package Mono 6.10, some Gtk libraries and Pinta itself.

1 Like

I’ve given this a go.

I’m not a Pinta user personally but from my quick experimenting it seems to work fine. It includes the official 6.10 release of Mono.

5 Likes

good job! seems to work fine :smiley:

2 Likes

@James-Carroll, thanks for packaging Pinta. I have tested it and it works fine.

But it looks like you have packaged older version of Pinta 1.6 that is 5 years old! But 6 days ago Pinta 1.7 was released (after 5 years of no new version) with over 50 bug fixes many of them crashes, freezes etc.

From Help | About there is prove 1.6 is installed from snap.

I also see @pixel above has Pinta 1.6 version, because in Pinta 1.7 there was removal of “x” from all three right site panels to make sure people do not accidentally close down panels and then not to know how to turn them on again.

Is it possible some how to package Pinta 1.7? But if you do, then please package Mono 6.10 with it from https://www.mono-project.com/download/stable/ because Pinta crashes and freezes a lot with older versions of Mono. A lot of reports on Pinta bug tracker about freezes/crashes both on Ubuntu 18.04 and Ubuntu 20.04.

I think the biggest advantage of having Pinta 1.7 installed from snap would be solving all this kind of dependency hell that is present if Pinta is installed using classical "sudo apt install "

Sorry about that, there’s something going wrong building Pinta where both it’s Git master repo and it’s .tar.gz sources are producing 1.6 binaries rather than 1.7.

I’ve worked around the problem in the meantime by using the official Pinta PPA binaries directly. The snap now definitely contains Pinta 1.7 in revision 3 (whereas 1 and 2 were 1.6 mislabelled in the Snap version as 1.7)

And I can definitely confirm it has Mono 6.10 in revision 3 too.

Hopefully everything is in order now, sudo snap refresh should clear this all up!

2 Likes

yep, now the snap is version 1.7

1 Like

@James-Carroll, thanks, that is great. You are awesome. I installed Pinta 1.7 snap and tested it. So far it looks everything is working fine. I haven’t found any problems. Thanks.

Just one little thing. If Pinta snap launched from terminal then some warnings/errors are returned.

mypc@tp:~$ pinta-james-carroll.pinta

'/snap/pinta-james-carroll/3/usr/lib/cli/glade-sharp-2.0' in MONO_PATH doesn't exist or has wrong permissions.
Gtk-Message: 16:43:42.693: Failed to load module "gail"
Gtk-Message: 16:43:42.693: Failed to load module "atk-bridge"
Gtk-Message: 16:43:42.696: Failed to load module "canberra-gtk-module"
Fontconfig warning: "/etc/fonts/conf.avail/53-monospace-lcd-filter.conf", line 10: Having multiple values in <test> isn't supported and may not work as expected

All above warnings are from Gtk#. I know the “canberra-gtk-module” warning is also reported on Pinta installed from Ubuntu PPA. For PPA version I have installed additional package manually:
sudo apt install libcanberra-gtk-module
and then all of the warnings disappeared.

I have now searched the web for above “Failed to load module” warnings and found:


Can you please look at those links above and see if you can add those packages to Pinta snap package?

I haven’t found any problems currently in Pinta 1.7 snap, but we never know if some future problem is going to appear because those packages are missing in snap. I would like to prevent those kind of problems before they appear.

Thanks.

I can fix the MONO_PATH warning for the next revision, but it is safe to ignore and isn’t a serious problem.

The GTK-Messages are pretty standard across most snaps and as you’ve noticed even often outside Snap environments. Echoing what I’ve seen across more experienced snap maintainers in these forums, the gist is just don’t worry about them. They’ll have a different list of complaints on various distros turning this into a game of whack a mole for every user, and they’ll generally not be useful for any given Snap. I wouldn’t expect the lack of them to influence Pinta in any way. Adding them would just be bloating the snap size to remove a small amount of terminal feedback where most people won’t ever open it via the terminal.

The fontconfig warning can probably be ignored again; although I think that font is from a native system package anyway rather than from the snap.

So in general I don’t expect any of those warnings to be problematic in the long term and I wouldn’t worry about their presence or lack of.

1 Like

Thanks for explaining. I thought there are some warnings that are Pinta snap specific and may cause problems. If there are known warnings and do not influence Pinta stability, then I fully agree not to add them to snap, no need to increase snap size if no benefit is added.

One more question. In Ubuntu 20.04 using Files program I can right click on .mkv or .mp4 and select Open With Other Application and select “VLC media player” which I have installed using snap.

But doing the same for .png or .jpg and selecting Open With Other Applications and there is no Pinta on the list. Is this part of snap package setting or is this setting outside of snap in Ubuntu itself?

Each app is supposed to provide the metadata that enables populating that list. I’ve added it to revision 4 which is live now and should fix it for you. Thanks again for the feedback!

3 Likes

@James-Carroll, I have updated it to revision 4 and now in Files if I select two files, right mouse click and select Open With Other Applications I see Pinta listed as program that can open images and selecting Pinta both files are opened in Pinta each in its own tab. This works as expected. Thanks a lot.

But I have also tested another case. By default on Ubuntu 20.04 “Image Viewer” program is set as default program to open image .png files. But this can be changed, for users that would like Pinta to be default program to open .png image files. I did:

  1. In Files right mouse click on one of the .png files and select Properties.
  2. Click on Open With tab.
  3. Mark Pinta and click on Set as default button. Pinta program has been moved from Recommended Applications to Default Application section.
  4. Click on “X” on title bar to close dialog.
  5. In Files select two .png files and right mouse click.
  6. Now there is direct option to select Open with Pinta. Click on it. PROBLEM appears. Now I expect both images are opened by single Pinta program instance, like explained in previous paragraph, but are not. There are opened with two Pinta program instances, each .png image in its own Pinta program.

I see in revision 4 you have added %U parameter to Exec line in pinta.desktop file:
grep Exec /snap/pinta-james-carroll/current/meta/gui/pinta.desktop

I have search the web and found the following web page explaining Exec parameters:
https://developer.gnome.org/desktop-entry-spec/#exec-variables
maybe some other parameter should be seleced.

1 Like

I have the same behavior with the APT package. This might be a bug in Files instead of Pinta itself.

1 Like

I think this might be the case. In Nautilus I get the behaviour of opening up several unique instances, whereas Dolphin handles it as expected and opens up one instance with several different tabs. As far as I’m aware, exec=pinta %U is correct (upstream uses %F, but I tried this on the off-chance and it didn’t change the results).

1 Like

This issue seems to be tracked here: https://gitlab.gnome.org/GNOME/nautilus/-/issues/117

It’s apparently wanted behavior because otherwise stuff would break when Nautilus runs inside of a Flatpak. There is an MR open to fix this issue, but this MR breaks Files running in a Flatpak: https://gitlab.gnome.org/GNOME/nautilus/-/merge_requests/518

2 Likes

Interesting. I have now installed Pinta from Ubuntu stable PPA and I see the same behavior. Also interesting I have tested this problem with Firefox browser and:

  • if Firefox is already opened and in Files select two .png images, images are displayed in current Firefox in two additional tabs,
  • if Firefox is closed and select two .png files in Files and first image is opened in Firefox and next one Firefox reports error that it is already opened

I tested the first option when “reporting” issue and now realized this is general behavior of Files. Sorry false report.

Thanks for investigating.