$PATH not expanded after snap (core) install

Hello forum readers,

I’m not sure in what category I should post this problem, but as a newbie I am restricted to ‘other’ I guess: I just installed snap today but it doesn’t expand my $PATH env variable and the other paths used to publish (make accessible) apps installed thru snap (I installed two: Drawing and PDF Mix Tool). App installs seem to be OK, but apps don’t show in GUI desktop menu and $PATH has no /snap/bin appended. I run Debian 11.4 with Bash for shell, Xfce for desktop and Snap 2.57.6. Found /etc/profile.d/apps-bin-path.sh but it doesn’t seem to be executed in any way. I tried execute it manually, rebooted twice, uninstalled and reinstalled Snap, nothing seems to work. How/where should this script be triggered or included? /etc/bash.bashrc perhaps?

Thanx in advance for any reaction given, Steijn van Essen (with 30 yrs ICT experience, but not so much in Linux, yet)

Did some reading about .bashrc & .profile & /etc/bash.bashrc & /etc/profile - the 2nd should invoke the 1st and the 4th should invoke the 3rd, as well as the scripts in the directory /etc/profile.d. Doesn’t seem to happen, though.

I copied /apps-bin-path.sh to my homedir, added some test lines, wrote a small script there to invoke it and printed some results: apps-bin-path.sh DOES expand my $PATH, but once it has finished the old $PATH (w/o /snap/bin added) is effective. Could be as to be expected, environment duplication for scripts and clean up on exit?, but I’m not a Linux pro (yet). But I proved that at least the ‘if’ statement in apps-bin-path.sh was executed.

Then made similar changes to /etc/profile.d/apps-bin-path.sh and rebooted my system. It seems that it is NOT invoked, because the test output generated in the first test did not come up in this second test.

Are there Linux pros out there that can give us a clue?

BTW: Should I have posted this problem at How to fix snap binaries not found ?