Package contains external symlinks to ieee-data


#1

Hello,

I suspect that I am missing something obvious here, but I would appreciate some help please!

I have a classic snap that is giving some warnings when running snapcraft:

/root/parts/duplicity/install/usr/lib/python2.7/dist-packages/netaddr/eui/oui.txt will be a dangling symlink
/root/parts/duplicity/install/usr/lib/python2.7/dist-packages/netaddr/eui/iab.txt will be a dangling symlink

and then when I try to upload it to the store I receive an error:

Error while processing...
The store was unable to accept this snap.
  - package contains external symlinks: usr/lib/python2.7/dist-packages/netaddr/eui/iab.txt, usr/lib/python2.7/dist-packages/netaddr/eui/oui.txt

Does anybody know how I should resolve this? It the latest version of a snap I have built and uploaded successfully before, so I’m guessing this dangling/external symlink check is new and it just wasn’t being caught before?

I tried adding ieee-data as a stage-package in my snapcraft.yaml because that looks like it is where that symlink points, but that did not change anything.

I also tried adding python-netaddr and ieee-data to my local system in the hope snapcraft might automatically pull them from the host.


#2

The check is not new (it is actually quite old) and I suspect that one of your dependencies changed in some way that caused this.

If you need the files, then you can just replace the dangling symlink with one that points to the right place in the snap or replace it with the file itself.

If you don’t need the files, you can add something like this to the snapcraft part that created the symlinks:

    stage:
    - -usr/lib/python2.7/dist-packages/netaddr/eui/oui.txt
    - -usr/lib/python2.7/dist-packages/netaddr/eui/iab.txt