Opera update issues

Hi, It’s many years now I’ve been using Opera web browser(snap) on my Linux Mint PC. All works well, just two issues I face regularly:

  1. Many times when an update of Opera takes places, I get various issues. At times trying to open Opera will not do anything, or, if it opens, all my data is wiped out - as if it’s a new installation of Opera.

  2. At times when I use Guest user, then I come back to my main user a/c and try to open Opera, it’s the same issue: all data is wiped out (as if it’s a new installation of Opera)

When all the data is wiped out, it can be really frustrating, as I have to way to recover my work like what were the open tabs.

Infact at this moment in time, it’s been two days I’ve not been able to user Opera - there was some update of Opera that took place and thereafter it just doesn’t start. So I tried to open from the terminal:

When trying to run as root (username has been replaced with xxxxx)

~$ sudo opera
[sudo] password for xxxxx:                   
mkdir: cannot create directory '/run/user/0': Permission denied
[77069:77069:1104/020533.256278:ERROR:zygote_host_impl_linux.cc(100)] Running as root without --no-sandbox is not supported. See https://crbug.com/638180.

When trying to run as no root (username has been replaced with xxxxx)

$ opera
cannot create user data directory: /home/xxxxx/snap/opera/272: Permission denied

I have also tried to take snapshots of Opera, so I can restore when data is wiped out, but I get errors there too:

~$ sudo snap save opera
error: cannot perform the following tasks:
- Save data of snap "opera" in snapshot set #5 (cannot create archive (showing last 5 lines out of 13):
tar: common/.cache/opera/Default/Cache/Cache_Data/fedf847b17f568a1_0: Cannot open: Input/output error
tar: common/.cache/opera/Default/Cache/Cache_Data/ea137558b7b223c6_0: Cannot open: Input/output error
tar: common/.cache/opera/Default/Cache/Cache_Data/51a55eaf719d631b_0: Cannot open: Input/output error
tar: common/.cache/opera/Default/Cache/Cache_Data/5303a54e2aad0928_0: Cannot open: Input/output error
tar: Exiting with failure status due to previous errors)

And again, it’s not only with this particular installation of Opera that I’m facing these issues. I’ve used Opera browser on for many years. During this time, I have had new installations on new PC’s but the issues have been there across all my different installations.

Would really appreciate some help on this, pls.