[ODROID][ARM64] Can't install Chrome or Firefox (Configure hook)

have you checked your kernel features with snap debug confinement and snap debug sandbox-features yet ?

my guess would be your kernel is missing features here …

This workarround solved my problem. I hope there is a better solution to be safe without disable the apparmor…

root@odroid:~# snap debug confinement 


root@odroid:~# snap debug sandbox-features 

apparmor:             kernel:caps kernel:domain kernel:file kernel:mount kernel:namespaces 

kernel:network kernel:policy kernel:rlimit parser:cap-audit-read parser:qipcrtr-socket parser:unsafe policy:default support-level:partial

confinement-options:  classic devmode

dbus:                 mediated-bus-access

kmod:                 mediated-modprobe

mount:                freezer-cgroup-v1 layouts mount-namespace per-snap-persistency per-snap-profiles per-snap-updates per-snap-user-profiles stale-base-invalidation

seccomp:              bpf-actlog bpf-argument-filtering

udev:                 device-cgroup-v1 device-filtering tagging

I have news.

Tried to reinstall Ubuntu again. This time I installed and used snap from the start. And it worked! So, this is not a kernel question. The point is that snap stops working just when I install gnome:

apt install gnome-session gdm3

1 Like