OBS Studio gives: Failed to load root certificates for a secure TLS connection. Check you have an up to date root certificate bundle in /etc/ssl/certs

Everything was set up as i have used to and worked and i tried to Snap version of OBS Studio. The regular .deb one (or whatever it is from PPA) does not throw this error with same settings.

Is this a bug or something? I would really like to get rid of PPA’s already but seems it’s impossilbe :confused:

Any help?

Good afternoon DZ,

I am having an identical problem trying to stream onto kick.com in these past few days.

did you by any chance find a solution? does anyone on here have a poss solution?

Hello to everyone btw, first post on here. been on ubuntu for a few years now.


Hello guys, first of all welcome to snapcraft forum @dziadulewicz & @interstellarg0

The problem is OBS snap isn’t maintained properly for almost an year now. If you guys are using Ubuntu 23.04 or deviatives, then use the OBS from the official repo. There will be as much I have tested no issue. But, for older versions of Ubuntu… I can’t say much. The OBS snap has some fundamental issues.

OBS’ Snap not maintained for a year!? WHAT is going on? This is one the most fundamentally most important packages!

I don’t remember did or did i not solve this, i have a small attention span and want these things to just work. I probably distro hopped on that particular machine without too much dicking around. Usually OBS works fine everywhere.