Nvidia beta drivers completely break snaps

I’m on Eoan dev build with nv vk beta drivers 418.52.17 installed.

Do note that these drivers are completely working fine outside snaps. If I install 430.xx drivers then snaps seem to work.

Snaps tested and failing to start

  • cncra
libGL error: failed to load driver: swrast
X Error:  GLXBadContext
  Request Major code 151 (GLX)
  Request Minor code 6 ()
  Error Serial #196
  Current Serial #195
  • cncra2yr
libGL error: No matching fbConfigs or visuals found
libGL error: failed to load driver: swrast
X Error:  GLXBadContext
  Request Major code 151 (GLX)
  Request Minor code 6 ()
  Error Serial #187
  Current Serial #186
  • leagueoflegends
007f:err:vulkan:wine_vk_instance_load_physical_devices Failed to enumerate physical devices, res=-3
007f:err:vulkan:wine_vkCreateInstance Failed to load physical devices, res=-3
terminate called after throwing an instance of 'dxvk::DxvkError'
  • mari0
libGL error: No matching fbConfigs or visuals found
libGL error: failed to load driver: swrast
X Error:  BadValue
  Request Major code 151 (GLX)
  Request Minor code 3 ()
  Value 0x0
  Error Serial #106
  Current Serial #107

This is how I fixed the libGL error in my snap:

I don’t think that will be needed since these snaps already have PATHS defined and are working fine on NVIDIA 430 drivers as mentioned in OP.

@mmtrt have you figured how to solve this?

libGL error: failed to load driver: swrast
X Error:  GLXBadContext

seems like i figured it out

1 Like

@mmtrt @zhuker how did you get the beta drivers onto your systems? I’d like to do the same for testing a fix.

This should do it.

sudo add-apt-repository ppa:graphics-drivers/ppa
sudo apt update
sudo apt install nvidia-driver-440

1 Like

Thank you. You should expect this to be fixed in a day or so.

Looking at https://launchpad.net/~graphics-drivers/+archive/ubuntu/ppa I’m assuming you meant nvidia-graphics-drivers-440

Thanks for looking into it.

Yeah 440 series has microversion which is current nv llb vk driver.

I’ve implemented the fix. Testing now on C&C Red Alert

2 Likes

good work, waiting for fix on edge :+1:

The pull request is up https://github.com/snapcore/snapd/pull/8067

2 Likes

The pull request has been merged. In several hours the edge build of snap will contain the fix. You can follow it by switching to core or snapd snap (if you have it) to follow the edge channel with snap refresh core --edge

Snaps working now :ok_hand:

1 Like

hi @zyga I have this exact issue on both manjaro and ubuntu 19.10
you can see my post herehttps://forum.snapcraft.io/t/im-building-a-mtg-arena-snap-and-have-some-issues/15826

I tried
snap refresh core --edge
and
snap refresh snapd --edge
and neither one of them worked any ideas?

i was told by @daniel to mention
that i tried snapd (via the snapd snap because i’m on the new world order) from both beta and edge but my snap still fails and i’m using the nvidia 440.59 drivers (i dont think they are beta)

-DM

1 Like

Manjaro does not support snapd re-execution from snap packages. You need to get an update to the Manjaro native package to get the fix.

what about ubuntu 19.10 ? it has the same issue.

@zyga a few people have this issue using the snap I’m building

you can find the source of the snap mtg-arena-snap
I can confirm it happens on Manjaro and Ubuntu 19.10