Not able to save file in Libreoffice Snap

I am not able to save file when I use Libreoffice snap version. It seems like all the files I open are opened in read-only mode. I even tried installing Libreoffice with --classic but to no avail.
Screenshot%20from%202020-11-03%2017-16-53

Is the file in a weird location? Do you get the same error when saving files in your home directory?

It is actually in my home directory. It is an .ods file, would that have anything to do with it? As docx on my Desktop works fine.

Okay it seems to be just related to Libreoffice Calc. I am not able to save documents, and it only opens them in read only mode.

An update on this situation, looks like I cannot save from Calc (snap version) on the root of my home directory But I can for example in Documents and Desktop. I can work with that, I should have my spreadsheets in Documents anyway to be more organized. Thanks.

Interesting. When you fail to save a file to the base of your home directory, is there any relevant log messages in the output of dmesg? In particular, messages about libreoffice being denied permission to open files.

The main difference in snapd’s treatment of your home directory compared to directories underneath it is that snaps won’t be able to create hidden files there (i.e. files whose name starts with a period). If LibreOffice is trying to create a hidden temporary file as part of the process of saving a file, then this would trip it up.

1 Like

I am only able to find this. Please let me know if you need more info, or direct me where to look

That looks like the log file for the application itself rather than the kernel’s log.

Try running sudo dmesg -H in a terminal, and search for messages containing libreoffice near the end after unsuccessfully saving a document.

I am seeing messages pointing to apparmor denied.
Created a text file, okay to upload it here?