Not a snap cgroup error

This is a new installation of Ubuntu Studio which was the first thing done after a ZFS file system was installed. The computer has a pair of SDD drives, and another pair of HDD drives. The SDD drives are RAIDed together, and the HDD drives are also raided together. All is encryopted on the ZFS level . The HDD drives contain the home directory pool. The SDD drives contain all other pools.

Because when I first booted after the Ubuntu Studio installation I could not find Firefox, I installed it using apt. The command and the response, is pasted farther below. The response indicates firefox was already installed. Yet the command seems to have installed something, and it is not clear to me what.

Now when I attempt to launch firefox I get this error:

2022/07/03 16:49:54.424008 cmd_run.go:1053: WARNING: cannot start document portal: Expected portal at "/run/user/1000/doc", got "/home/stephen/.cache/doc"
    /system.slice/sddm.service is not a snap cgroup

Below is an excerpt from the systemd-cgls command output:

Control group /:
│ └─1 /sbin/init splash
  │ ├─ 4155 /usr/bin/sddm
  │ ├─ 4346 /usr/lib/xorg/Xorg -nolisten tcp -auth /var/run/sddm/{c2985236-69a5-41fc-bc30-f25>
  │ ├─ 4869 /usr/lib/x86_64-linux-gnu/sddm/sddm-helper --socket /tmp/sddm-auth2e0148a3-75ed-4>
  │ ├─ 4882 /usr/bin/kwalletd5 --pam-login 7 8

It appears to me that according to the systemd-cgls command that “/system.slice/sddm.service” is a cgroup. This is contrary to the error message. What accounts for this discrepancy?

How do I recover from this, and get Firefox working?

In an attempt to solve this I used the apt command to purge firefox, followed the snap command that also purges it. I then used snap to reinstall firefox. But this did not solve it. I still get the same error message when I attempt to launch Firefox.

I also tried the command “sudo snap refresh”. This too did not solve it.

In case the procedure I used to install ZFS has any bearing on this cgroup trouble I have, I made the procedure I used to install ZFS, and Ubuntu Studio, available for download at: This document was created using LibreOffice Writer. It is a record I use to keep track of what I did for future reference.

The firefox install command I used, and its response:

$ sudo apt --yes install firefox
[sudo] password for stephen: 
Reading package lists.. Done
Building dependency tree.. Done
Reading state information.. Done
The following NEW packages will be installed:
0 upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
Need to get 72.3 kB of archives.
After this operation, 261 kB of additional disk space will be used.
Get:1 jammy/main amd64 firefox amd64 1:1snap1-0ubuntu2 [72.3 kB]
Fetched 72.3 kB in 1s (137 kB/s)
Requesting to save current system state
Successfully saved as "autozsys_oaq4s7"
Preconfiguring packages ..
Selecting previously unselected package firefox.
(Reading database .. 251528 files and directories currently installed.)
Preparing to unpack ../firefox_1%3a1snap1-0ubuntu2_amd64.deb ..
=> Installing the firefox snap
==> Checking connectivity with the snap store
==> Installing the firefox snap
snap "firefox" is already installed, see 'snap help refresh'
=> Snap installation complete
Unpacking firefox (1:1snap1-0ubuntu2) ..
Setting up firefox (1:1snap1-0ubuntu2) ..
update-alternatives: using /usr/bin/firefox to provide /usr/bin/gnome-www-browse
r (gnome-www-browser) in auto mode
update-alternatives: using /usr/bin/firefox to provide /usr/bin/x-www-browser (x
-www-browser) in auto mode
Processing triggers for desktop-file-utils (0.26-1ubuntu3) ..
Processing triggers for hicolor-icon-theme (0.17-2) ..
Processing triggers for mailcap (3.70+nmu1ubuntu1) ..
ZSys is adding automatic system snapshot to GRUB menu
stephen@stephen:~$ firefox
/system.slice/ssh.service is not a snap cgroup

I have recently discovered:

  1. The global variable XDG_RUNTIME_DIR is not set to anything.

  2. There is only one user on this newly installed Ubuntu 22.04 OS. It would be expected the user number for it is 1000. This is verified by the global $UID being set to that number as expected. But the directory /run/user/1000 does not exist. The directory /run/user/ is empty.

pam_systemd is supposed to set XDG_RUNTIME_DIR, and create /run/user/1000. It is failing to for reasons I do not know.

I have made syslog available for download at: .

Any help with this would be much appreciated.

I have firefox working. To get it to work I had to disable cgroup. To do this I followed Tim Richardson’s instructions at c25. When launched it outputs many permission denied errors which are attached.

I do not know what to do about these errors. Before I can use the installation these have to be solved. For this I will start a new thread.