No sounds on snapcraft applications


#1

Hey Everyone

So Here is the problem i’m on the raspbian OS and I’ve installed a few applications with canonical’s snapcraft store .The problem is that There is no sound in any of these applications . For exemple, when I launch retroarch with " snap run retroarch" the application work but I have no sound and I have this message in the terminal;

ALSA lib conf.c:3750:(snd_config_update_r) Cannot access file /usr/share/alsa/alsa.conf

ALSA lib pcm.c:2266:(snd_pcm_open_noupdate) Unknown PCM default

ALSA lib conf.c:3750:(snd_config_update_r) Cannot access file /usr/share/alsa/alsa.conf

ALSA lib seq.c:935:(snd_seq_open_noupdate) Unknown SEQ default

So is there anybody who knows what is the problem is and how to solve it?


#2

Most snaps require the pulseaudio daemon that is usually started by your session. If you are not in a graphical environment then you need to start it yourself. Alternatively, if the snap is built to be able to use alsa then you can snap connect snap-name:alsa to give it access to the sound hardware directly.


#3

yes, I’m in a graphical environment so i tried connect snap-name:alsa with retroarch and it is said " error: snap “snap-retroarch” has no plug named “alsa” but the thing is when i type snap connections retroarch, I can see a plug named alsa.


#4

sounds like you are using the command the wrong way around …

sudo snap connect retroarch:alsa

#5

I tried sudo snap connect retroarch:alsa, then, run retroarch, but unfortunately i still have no sound and the same error message that i show previously in this topic.