No sound inside Ubuntu Core 20.04

My Ubuntu Core device can’t seem to produce any sound. At first I thought I had issues, with my snap, but later on, I tried another snap “mpv-kiosk”, but it too had the same problem. No sound. Am i missing something? Any help would be really helpful. I have trying to fix this issue for several days now. Thanks

Here is the link to mpv-kiosk ( github ): Snapcraft mpv-kiosk:

you can use the pulseaudio snap from the beta channel:

snap install pulseaudio --beta

make sure the audio-playback interface of apps is connected to pulse …

there are also some hints how to use pulse on an UC20 device (control volume etc) in the README:md at:

Hi @ogra. Thanks for the reply. My audio-playback plug is already connected to pulseaudio and I downloaded pulseaudio from the beta channel. I tried increasing the volume. But no luck. No sound. By the way, I am using a Virtual Machine. Do you think the sound issue, might be related to that?

well, if your virtual machine usually plays audio it should with Ubuntu Core as well … check with

sudo pulseaudio.pactl list sinks

to see if you have more than the dummy output device …

if you do, but there are multiple sinks returned, you might need to switch the default output sink using

sudo pulseaudio.pactl set-default-sink $Name-that-the-above-returned

Hi @ogra. Sorry for the late reply. I tried this sudo pulseaudio.pactl list sinks command and got the following output.

Sink #0
	Name: alsa_output.pci-0000_00_05.0.analog-stereo
	Description: Built-in Audio Analog Stereo
	Driver: module-alsa-card.c
	Sample Specification: s16le 2ch 48000Hz
	Channel Map: front-left,front-right
	Owner Module: 6
	Mute: yes
	Volume: front-left: 10387 /  16% / -48.00 dB,   front-right: 61870 /  94% / -1.50 dB
	        balance 0.83
	Base Volume: 65536 / 100% / 0.00 dB
	Monitor Source: alsa_output.pci-0000_00_05.0.analog-stereo.monitor
	Latency: 70202 usec, configured 99937 usec
		alsa.resolution_bits = "16"
		device.api = "alsa"
		device.class = "sound"
		alsa.class = "generic"
		alsa.subclass = "generic-mix" = "Intel 82801AA-ICH" = "Intel ICH"
		alsa.subdevice = "0"
		alsa.subdevice_name = "subdevice #0"
		alsa.device = "0"
		alsa.card = "0"
		alsa.card_name = "Intel 82801AA-ICH"
		alsa.long_card_name = "Intel 82801AA-ICH with AD1980 at irq 21"
		alsa.driver_name = "snd_intel8x0"
		device.bus_path = "pci-0000:00:05.0"
		sysfs.path = "/devices/pci0000:00/0000:00:05.0/sound/card0"
		device.bus = "pci" = "8086" = "Intel Corporation" = "2415" = "82801AA AC'97 Audio Controller"
		device.form_factor = "internal"
		device.string = "front:0"
		device.buffering.buffer_size = "19188"
		device.buffering.fragment_size = "6396"
		device.access_mode = "mmap" = "analog-stereo"
		device.profile.description = "Analog Stereo"
		device.description = "Built-in Audio Analog Stereo"
		alsa.mixer_name = "Analog Devices AD1980"
		alsa.components = "AC97a:41445370"
		module-udev-detect.discovered = "1"
		device.icon_name = "audio-card-pci"
		analog-output;output-amplifier-on: Analog Output / Amplifier (priority: 9910)
		analog-output;output-amplifier-off: Analog Output / No Amplifier (priority: 9900)
	Active Port: analog-output;output-amplifier-on

After that I used the command

sudo pulseaudio.pactl set-default-sink alsa_output.pci-0000_00_05.0.analog-stereo

But still no sound.

well, it looks all okay and pulseaudio thinks it is currently playing sound through a headphone jack (State: RUNNING) …

do you perhaps need to set up something on your host ?

try using pavucontrol on the host, perhaps the audio from the VM is simply not routed correctly on the host …

From your list sinks output:

You’re going to want to run $ pactl set-sink-mute {sink_name} 0

1 Like