`no asset from the kernel.yaml needing synced update is consumed by the gadget at "/.*"`

Hi, I am getting this error when trying to build an image with custom gadget snap on the pi4.
It worked just recently, not sure what changed here.

I saw there were few changes in the pi-gadget repo - i.e. device-tree gone in gadget.yaml so I tried bringing them to my code.

So what I found was that at this point I was not able to build an image in docker container errors.
After installing the latest ubuntu-image from snapcraft and rebuilding with it I got the exact same error I had on the device in the build process.

I see it here - https://github.com/snapcore/snapd/blob/master/image/image_test.go#L3025
unfortunately, it’s kinda difficult to understand what it means without context.

How can I fix this?


also, your field engineer should have contacted you over the last 6 weeks to notify you about this required change to your gadget …

1 Like

Yeah, I managed to get it working now thank you. Not sure if anyone contacted us, going to find that out.

I am so confused by another thing though, though it might be unrelated to those changes? So my Qt 5 + mesa v3d app failed to start, after doing some investigation I found that it now worked when
instead of /dev/dri/card1 I used /dev/dri/card0.
From what I know is not card1 used for rendering? Do you know why it changed? can it be related to those changes?

Just a month ago or so I tested and it all worked as expected on card1

that would be a question to @waveform i fear, not sure if anything changed here … while i see that config.txt changed in classic installs from the fkms driver to kms (which breaks a lot of things here for me on a classic install), this change has luckily not been made in the core gadgets AFAIK

Just a side note about configs as well: cma-128 is used as a default on pi4, which does not really make sense. Makes a video playback unstable.

It’s also not a default value on pi4, if you do not specify it in dt_overlay when enabling fkms it should be 256.
I see in logs that it was explicitly set to 256 as well but was decreased to 128 mb so that it works on older pis as well. But fkms is not working well on older pi models anyhow.

hmm, i have not seen it working badly on either pi2 or 3 for any kiosk apps i used yet and fkms is the only one that gives you working MMAL video decoding (i do run 1080p playback on kiosk systems on pi2 with ubuntu core with the kodi-pi-standalone or vlc-pi snaps just fine)

While I did not use fkms a lot on older pis that’s also what pi engineers say themselves as well in some of their github issues, there is not enough ram for it work properly.