Need some help with creating a snapcraft.yaml

Hello Dear members of this community.
I need your little help to check following yaml file that i need to create for X11VNC forked from Thank you beforehand!

name: my-snap-name # you probably want to 'snapcraft register ’
version: ‘0.1’ # just for humans, typically ‘1.2+git’ or ‘1.3.2’
summary: Single-line elevator pitch for your amazing snap # 79 char long summary
description: |
This is my-snap’s description. You have a paragraph or two to tell the
most important story about your snap. Keep it under 100 words though,
we live in tweetspace and your description wants to look good in the snap

confinement: devmode # use ‘strict’ once you have the right plugs and slots

command: xwayland-kiosk-launch /usr/bin/x11vnc
- opengl
- wayland
- autotools

- g++
- make
- libsdl1.2-dev
- libpng-dev
- libsdl-net1.2-dev
- libsdl-sound1.2-dev
- libasound2-dev
# See ‘snapcraft plugins’
plugin: nil

after: [ xwayland-kiosk-helper ]
- libsdl-sound1.2
- libsdl-net1.2
- libxcursor1
- libxi6
- libxinerama1
- libxrandr2
- libxrender1
- libopenal1
- libsndio6.1
- libspeex1
- libvorbisfile3
- libwayland-client0
- libwayland-cursor0
- libwayland-egl1-mesa
- libxkbcommon0
- libglu1-mesa
- libasound2
- libasyncns0
- libbsd0
- libcaca0
- libdbus-1-3
- libflac8
- libgcc1
- libgcrypt20
- libgl1
- libglvnd0
- libglx0
- libgpg-error0
- liblz4-1
- liblzma5
- libncursesw5
- libogg0
- libpng16-16
- libpulse0
- libsdl1.2debian
- libslang2
- libsndfile1
- libstdc++6
- libsystemd0
- libtinfo5
- libvorbis0a
- libvorbisenc2
- libwrap0
- libx11-6
- libxau6
- libxcb1
- libxdmcp6
- libxext6
- zlib1g

Just wanted to tell that i’ve managed to correct the yaml file, It works fine though took a lot of effort to figure out.

Sorry what is the error you’re experiencing? Have you tried building it? I think you’ll need to give a little more info before you can get much feedback.

while this is very old (and badly maintained, i havent tried it in a while), my xdmcp-client snap does a similar thing:

perhaps you can steal some code from it for inspiration :wink:

Hello Ogra,

Thank you for help and offering the solution. I will try to fix my own snap and if not succeed then will resort to your snap.

Have a nice day/night.


Hello Ryanjyoder, Thank you for helping!

Is the Snap folder should be inside of forked folder? But I’ve found it in inside of my home folder.
I’ve run snapcraft cleandbuid command and so far got following messages coming

Creating snapcraft-barbarically-biotechnological-jocelyn
Starting snapcraft-barbarically-biotechnological-jocelyn
Waiting for a network connection…
Network connection established
Get:1 xenial-security InRelease [109 kB]
Hit:2 xenial InRelease
Get:3 xenial-updates InRelease [109 kB]
Get:4 xenial-backports InRelease [107 kB]
Get:5 xenial/universe amd64 Packages [7532 kB]
Get:6 xenial-security/main amd64 Packages [679 kB]
Get:7 xenial/universe Translation-en [4354 kB]
Get:8 xenial-security/main Translation-en [272 kB]
Get:9 xenial-security/universe amd64 Packages [440 kB]
Get:10 xenial/multiverse amd64 Packages [144 kB]
Get:11 xenial/multiverse Translation-en [106 kB]
Get:12 xenial-updates/main amd64 Packages [976 kB]
Get:13 xenial-updates/universe amd64 Packages [752 kB]
Get:14 xenial-updates/universe Translation-en [314 kB]
Get:15 xenial-updates/multiverse amd64 Packages [16.7 kB]
Get:16 xenial-updates/multiverse Translation-en [8440 B]
Get:17 xenial-backports/main amd64 Packages [7280 B]
Get:18 xenial-backports/main Translation-en [4456 B]
Get:19 xenial-backports/universe amd64 Packages [7804 B]
Get:20 xenial-backports/universe Translation-en [4184 B]
Get:21 xenial-security/universe Translation-en [179 kB]
Get:22 xenial-security/multiverse amd64 Packages [5604 B]
Get:23 xenial-security/multiverse Translation-en [2676 B]

I dont know if it works at this time.

Have a nice day/night.