[nano] Snap lists app but can not open app


#1

Hello,

I installed nano and pinano but when I try to run the program I get
@localhost:~$ nano
nano: command not found

But I can see that the program is installed because when I try listed is there and if I try to install it it tells me that is already installed.

@localhost:~$ snap list
Name Version Rev Tracking Publisher Notes
classic 16.04 42 edge canonical✓ devmode
core 16-2.38 6676 stable canonical✓ core
nano 3.2+pkg-24de 29 stable snapcrafters -
pi2-kernel 4.4.0-1106.114 85 stable canonical✓ kernel
pi3 16.04-0.6 27 stable canonical✓ gadget
pinano 2.9.8 12 stable vbota -

The only difference I see from the other programs is that the Notes column is empty.

I am running sudo classic but this happens if I just run it in regular mode as well.

Any help will be welcome


#2

Please run the printenv | grep ^PATH command and report the output.

This snap is now obsoleted, for Ubuntu Core systems please use the nano-strict snap.


#3

Hi Lin,

Thanks for the reply, here is the output

PATH=/home/fzorrilla/bin:/home/fzorrilla/.local/bin:/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games:/usr/local/games:/snap/bin


#4

As the /snap/bin directory is in you command search PATHs it should be launch-able by using the nano command.

Is it reproducible outside the classic environment?


#5

yes same result on classic, I can not launch any snaps.

This is another example:

(classic)fzorrilla@localhost:~$ systemctl status snap.networkmanager
● snap.networkmanager.service
Loaded: not-found (Reason: No such file or directory)
Active: inactive (dead)

So I do not know which directory is not finding


#6

To be clear I get the same result using classic or outside of it.


#7

I found out that if I go directly here @localhost:/snap/bin I can launch the app.
But I can not still do it from my user directory. Does it have to do with this: nano -> /usr/bin/snap*


#8

And now it works, after running then apps from @localhost:/snap/bin a snap folder was create on the user location and now I can launch them from there. I do not know if this is by design or just a fluke.


#9

That command should only work out of classic environment AFAICT.

Not at all, as the /snap/bin directory is in your shell’s command search PATHs it should work by default.

It isn’t designed to work like this.


#10

Note that in the classic environment you should be able to run sudo apt install nano to install the debian distribution of nano.

It shouldn’t work out of the classic environment, though.