MX Linux 21,(debian 11)

Refuses to install snap-store, Can’t “Find, communicate, with installed snapd”!

Have you run systemctl status snapd.service? If it’s down, it may be enough to enable the socket systemctl enable --now snapd.socket.

And first you need to have systemd running. From

sysVinit remains the default init system. systemd is available as a boot option on installed systems (but not on live systems). In other words, exactly the same as MX19.

Thanks for the reply, but I’m afraid it was quite a bit more involved. Firstly, I had to change a bit, so it would run “systemd”, then, it could find/communicate, with snapd, and install “snap-store”, problem continues as although there, snap-store, will not load. And I thought, “getting away from Windows”, would be good, have now tried, some 20+ various distro’s, every-one, is basically “Screwed”, none do as they promise! Only 1 that came close, was Linux Mint, but after 19.3, they screwed that too. I’m guessing, all the "out of work windows programmers/developers, now work on Linux, as a “payback”,to us who left, when they dropped support for 7. It’s not as though, I run “Crap”,either, still have my dual processor media server, plus 2 Ryzen, powered servers, and my laptops. Getting to the stage, where,next purchase, could be some petrol,matches, and enjoy the fire. Yours wolfy(Club-name) Peter.