Mount snap "snapd" (10707) failed with exit status 1

Okay i give up, i have tried a gazzilion things but cant for the life of me fix this :confused:

I am new to arch linux and being a debian user it is kinda hard to shift , so first thing i had to install snap, that’s one of the easiest ways to install applications

but after following the steps to install snap on arch linux, the installations is succesfull but i am not able to install any apps

error: cannot perform the following tasks:

  • Mount snap “snapd” (10707) ([start snap-snapd-10707.mount] failed with exit status 1: Job failed. See “journalctl -xe” for details.)

Pls help Thank you :slight_smile:

This may be a problem with squashfs support in your kernel. Can you attach the journal logs from the time you tried to install the snap?

Hey, I was using Garuda KDE Dragonized edition, it was a fresh install still something was wrong, but for now I just got rid of it

It is most likely their kernel misses security and/or filesystem features (i.e. squashfs support) …

i have the same problem please help

i fear you have to ask garuda to add the missing pieces to their kernel config

okay i will post this in garuda linux wiki
thank you