Mosaic not running in ubuntu 19.10 - not root-owned 33:33

I installed mosaic with this:

$ sudo snap install mosaic

Then I tried to run it with.

$ mosaic
zsh: command not found: mosaic

I add the /snap/bin to my PATH:

$ export PATH=/snap/bin:$PATH

And tried to run mosaic again with no luck:

$ mosaic
/var/lib/snapd/seccomp not root-owned 33:33

What I am doing wrong?


Can you post the output of

$ snap version


It is unexpected that /var/lib/snapd/seccomp is not root-owned, this is a security feature however where snap-confine refuses to run since an attacker may have modified the files inside /var/lib/snapd/seccomp.

$ snap version
snap    2.42.5
snapd   2.42.5
series  16
ubuntu  19.10
kernel  5.3.0-24-generic

Where did you get the ubuntu image from? Did you download it from cdimage? I launched a 19.10 VM and was unable to reproduce this issue.

I found the problem. I do not why, but the permission in


were wrong

Thanks for the help!

That’s great you were able to work-around it!

In case this is an issue with the image you used to install Ubuntu, I’m still curious where the Ubuntu image you used came from so we can try to get that issue corrected in the image (as well as the issue with /snap/bin missing from $PATH) for other users.

I downloaded the iso file from
I think the issue with the permissions was my fault while migrating from a laptop to another some time ago… don’ t care about it. But the issue with the $PATH it is strange…