Missing shared library for DigiKam

Hi everyone,

I installed the latest version of DigiKam through Ubuntu Software application. From the description, I gather that it was the Snap version that was installed.

Once installed, when I try to launch DigiKam from the graphical interface, nothing happens.

From the command line, I get the following error:

/snap/digikam/4/usr/bin/digikam: error while loading shared libraries: libQt5Sql.so.5: cannot open shared object file: No such file or directory 

When I search for the lib, I find it:

$ whereis libQt5Sql.so.5
libQt5Sql.so: /usr/lib/x86_64-linux-gnu/libQt5Sql.so /usr/lib/x86_64-linux-gnu/libQt5Sql.so.5

From the installer application, I set up the following permissions : Access files in your home folder, Read system mount information and disks quotas, and Read/write files on removable storage devices.

The provided version in Software is 6.3.0, last updated 12/10/2019. My Ubuntu version is 18.04 LTS, if that can help.

Is there anything I missed while installing through Snap?


how are you launching it from the commandline?

I start a command line, and enter:

$ digikam

Is this what you meant?

Yes, that was what I meant.

I just installed it locally and got the same error, for what it’s worth; you’re not doing anything wrong, and there’s a bug in the snap.

Did you notice digikam was only available in a “beta” channel? (and “edge” which is even higher risk) That’s usually an indicator that the author (of the snap, not necessarily of the software) doesn’t think it’s ready for general use.

If you didn’t notice, it might be worth having a chat with the Software people.

Thank you for your reply. Actually I did notice, though I also noticed that DigiKam was labelled as Proprietary. That puzzled me and I think I didn’t take the description as accurate.

Also, I must admit that I new to using Snap, I’m much more used to install software packages through APT.

is it “proprietary”, or is it “unset”? It should be “unset”, if Software has that. The snap author simply hasn’t set the license yet. It might be that Software considers anything not explicitly Free to be proprietary, and that’s a reasonable choice (not one I agree with but ok).

For what it’s worth I notice this snap’s author, @sergiusens, is reasonably active here (being one of the developers of snapcraft itself), so maybe he has input on this.

Thanks for the precisions. On Software, it’s labelled as Proprietary although I can’t tell you why. It’s indeed either strange or a bug not to label an unset license as unset; I’ve also checked on the Snap command line utility the available information, I may install through it in the future.

For now I’ll wait for the DigiKam stable update. :wink:

The problem is that you need to snap connect the content interface. A nice language to describe mandatory connections in snap.yaml would be nice :slight_smile:

@sergiusens I’m new to this all. How would one snap connect the content interface?

I’m also new to this. I played around and found this made it work:

sudo snap connect digikam:kde-frameworks-5-plug kde-frameworks-5-core18:kde-frameworks-5-core18-slot

FYI, here’s how I figured it out: (I don’t know what I’m doing, someone else correct me here. :smiley:)

snap connections digikam

… showed an unset plug called digikam:kde-frameworks-5-plug.

I used snap list to find snaps that might apply (there’s probably a better way) and saw kde-frameworks-5-core18 installed. So I then did snap connections kde-frameworks-5-core18 and saw two connections with the “content” interface, so I chose the more generic looking one :slight_smile:, kde-frameworks-5-core18:kde-frameworks-5-core18-slot

Hope that helps!

Hi @jerph!

Your solution worked for me like a charm. It also helped me advance in my understanding of snap.

Thanks !