Missing Dutch interface language in LibreOffice Snap

Hi. My native language is Dutch, I live in the Netherlands, but when I get the LibreOffice packages from Ubuntu Linux (Snap), I can choose from only 15 interface languages, and Dutch is not one of them. Even though Dutch is available as interface language on the generic LibreOffice that can be downloaded from the LibreOffice website, but that isn’t automatically updated. For Dutch people who aren’t very good at English, or are good at it but still want the Dutch interface language, this is a bit of a problem, especially because it isn’t at all obvious how you can download & install a separate language pack. This topic in Ask LibreOffice is about the same problem (warning: text in Dutch): https://ask.libreoffice.org/t/kan-de-user-interface-taal-niet-veranderen/73301/5 Can this be fixed?

Currently on: Version: / LibreOffice Community Build ID: 711f8d38e9451cd2fd39b6963d2a3fc166f04cb1 CPU threads: 4; OS: Linux 5.4; UI render: default; VCL: gtk3 Locale: nl-NL (nl_NL.UTF-8); UI: en-US Calc: threaded

Please file a bug at https://bugs.launchpad.net/ubuntu/+source/libreoffice/+bugs?field.tag=snap.

Okay, thanks for the heads-up. Thing is, I asked a question about that at launchpad and they sent me here. :thinking: Bug report at Bug #1960014 “Missing Dutch language interface for LibreOffice i...” : Bugs : libreoffice package : Ubuntu

Hm the person who directed you here may have not been aware of the snap tag that libreoffice apparently has in LP. FWIW, the snap info libreoffice command shows this:

name:      libreoffice
summary:   LibreOffice is a free and open source office suite
publisher: Canonical✓
store-url: https://snapcraft.io/libreoffice
contact:   https://bugs.launchpad.net/ubuntu/+source/libreoffice/+bugs?field.tag=snap
license:   MPL-2.0
description: |
  LibreOffice is a free and open source office suite, developed by The Document Foundation. The
  LibreOffice suite comprises programs for word processing, the creation and editing of
  spreadsheets, slideshows, diagrams and drawings, working with databases, and composing
  mathematical formulae.
snap-id: CpUkI0qPIIBVRsjy49adNq4D6Ra72y4v
  latest/stable: 2022-01-31 (242) 646MB -
  latest/candidate: 2022-01-22 (242) 646MB -
  latest/beta: 2022-01-31 (244) 649MB -
  latest/edge:      ↑   

where the LP url is listed as contact point (bug reporting too?). My guess is just file a bug there.

Like I see it LibreOffice snap package is distributed with few language interfaces only. Missing most of the languages of the world.

I checked LibreOffice Flatpak version and I see Flatpak besides Libreoffice package: org.libreoffice.LibreOffice also installs language package: org.libreoffice.LibreOffice.Locale

Flatpak looks to me it somehow checks “locale” (Linux command) of current computer and installs only the language interface set by locale (additional to English language installed by default). My locale language interface works fine in my case.

I think LibreOffice snap should go similar way. To create language extensions as additional snap package.

I tried to manually create extension and install it, but for some reason this is NOT! working.
  1. Create directory where we will extract files and change dir to it.
mkdir ~/temp_libreoffice
cd ~/temp_libreoffice
  1. From terminal check installed LibreOffice snap version.

/snap/bin/libreoffice --version

  1. It returns like: LibreOffice 711f8d38e9451cd2fd39b6963d2a3fc166f04cb1

Remember first three numbers so in this case: 7.2.5 Also get your language (e.g. locale command on Linux terminal).

  1. Now download LibreOfficre package file. But from previous step replace X.X.X with 7.2.5 and YY with language you get e.g. “nl” for Nederlands.


Now we get:

wget https://download.documentfoundation.org/libreoffice/stable/7.2.5/deb/x86_64/LibreOffice_7.2.5_Linux_x86-64_deb_langpack_nl.tar.gz

  1. Extract downloaded file and change dir to it.
tar xf LibreOffice_*
cd */DEBS/
  1. Unpack dictitonary deb file.

ar x libreoffice*-dict-*.deb

  1. Untar file.

tar xf data.tar.xz

  1. Change dir to sub dirs.

cd opt/libreoffice*/share/extensions/dict-*/

  1. Zip extension.

zip language_extension.oxt *

  1. Copy extention to your home directory.

cp language_extension.oxt ~

  1. Change path to your home directory.

cd ~

  1. Clean everything we made (except copied file from step 10).

rm -rf ~/temp_libreoffice

  1. Run LibreOffice snap.


  1. From LibreOffice GUI menu: Tools | Extension Manager and lick on Add button.

  2. Select file from /home/[user]/language_extension.oxt and then press Close button in Extension Manager

  3. “Restart Now” button

  4. Menu Tools | Options

  5. On left site of panel: Language Settings | Languages

  6. In right panel on top there is section “Langauge Of” selection “User interface”. And there should be “Nederlands” user interface but for some reason there isn’t one.

Like I see it @floris-v until this is fixed in LibreOffice/snap you have two options (uninstall LibreOffice snap as first step):

  1. Install LibreOffice PPA and install language support.
  2. Install LibreOffice Flatpak (language support is installed automatically).

I went the Flatpak road and it works fine.

1 Like