Missing app icon on snapcraft.io

When you visit https://snapcraft.io/boxy-svg you can notice that the app icon is missing. I tried setting the icon manually via the developer dashboard, but no matter which format and size I choose it would still not fix the problem.

How was the icon file generated? When opening the file in it’s own tab, Firefox on Win 11 complains to me that the image file is corrupted. Link

Could you upload the icon here in the forums to see if it looks valid outside the store UI?

Hi, it looks like it’s on our side due to a caching issue. The source image is (Discourse nicely renders it as broken for now):

If you use a different URL to force re-caching, it works:

Leave this with us, we’ll get it fixed.

  • Daniel

The issue seems to be fixed now, thanks!

I think i experienced similar issues with the screenshot images for my app. They were broken for weeks, intermittent at times. Looks like they are displaying ok since earlier this week.

I just installed snap-store snap on a fresh virtual machine to check whether it is showing my app metadata correctly. Unfortunately it fails to load the app icon and screenshots (even though they are shown correctly on https://snapcraft.io/boxy-svg)

I tried reuploading the screenshots and now they fail to load on https://snapcraft.io/boxy-svg page too.

Update: Screenshots are now shown correctly on https://snapcraft.io/boxy-svg, but they are still missing on the Snap Store. The app icon is shown correctly on both places.