Minecraft 2.1.1218 works until reboot

I recently found out Minecraft had been snapped, so I downloaded it and started playing again. :smiley:

snap install minecraft

Everything was going fine until I shutdown my system and started it up the next day. Upon clicking the Minecraft entry in my apps menu, nothing happened. I then opened a terminal and typed:

minecraft

To my surprise I got the following 2 errors spit out on the screen. :open_mouth:

cannot change profile for the next exec call: No such file or directory snap-update-ns failed with code 1: No such file or directory

I then proceeded to

snap remove minecraft snap install minecraft

All was well and working once again. :slight_smile: Shutdown and startup of my system the next day and… I got the same 2 errors again. :frowning: Am I doing/configuring something wrong or is this a bug?

I have figured out how to switch channels and I am going to try edge version 2.1.1349 to see if it still happens. I will post back with my findings soon as I can.

snap verion: snap 2.32.9 snapd 2.32.9 series 16 solus 3.9999 (Budgie version) kernel 4.17.14-86.current

Hello

We’ve seen some reports about issues affecting Solus but we cannot update snapd there directly. Can you please check if your system is fully up to date?

If the problem persists on a fully up-to-date system we can investigate if something new is happening.

Software Center and “eopkg up” both say up to date as of Fri Aug 24 2018 @ 03:11:31 CDT

That’s interesting, can you please provide:

systemctl status aa-lsm-hook.service

You may want to restart that service with systemctl restart aa-lsm-hook.service but I’m not sure if this will resolve your issue.

Hmm… interesting result.

● aa-lsm-hook.service - Load AppArmor profiles
Loaded: loaded (/usr/lib/systemd/system/aa-lsm-hook.service; disabled; vendor preset: enabled)
Active: inactive (dead) since Fri 2018-08-24 13:34:56 CDT; 1min 0s ago
Process: 1845 ExecStart=/usr/sbin/aa-lsm-hook-load (code=exited, status=0/SUCCESS)
Main PID: 1845 (code=exited, status=0/SUCCESS)

Aug 24 13:34:56 elite-solus systemd[1]: Starting Load AppArmor profiles…
Aug 24 13:34:56 elite-solus systemd[1]: Started Load AppArmor profiles.

Even tried restart and start, same result.

P.S. I should also note, switching to edge version did not change anything.

I decided to find out if it is just the Minecraft snap or any snap.
So, I installed the discord snap.
Launched fine, rebooted…
Low and behold, same errors after reboot that I have with the Minecraft snap.

So, thanks to https://dev.solus-project.com/T6499, I have started to narrow down the problem.
The following command fixes the 2 errors and allows me to launch snaps until reboot.

sudo apparmor_parser -r /var/lib/snapd/apparmor/profiles/*

I do not see a fix or suggested solution on the thread, but at least it appears to be narrowed down to apparmor.
Any ideas where to go next?

We know about this issue but it’s a customization done by Solus. What is unclear is why the solus-specific aa-lsm-hook service does not load the profiles on your machine. I would suggest that you try to debug that (run it under strace, etc) until we get an answer.

Because I really don’t like finding posts where the solution is never posted. Here is what solved my problem and hopefully it solves someone else problem someday.

Thanks goes to sunnyflunk on the #Solus IRC channel.

sudo usysconf run -f

More info on the command here: https://github.com/solus-project/usysconf

So far, 3 full power downs and snaps run after login like they are supposed to. No extra commands before running a snap anymore. :smile: :wink:

2 Likes