Microk8s installation on Ubuntu

I am new to Docker / Kubernetes, going through one of the Udemy course. When I configured k8s through microk8s on my ubuntu machine machine, by default it installed 1.18 but then I downgraded it to V1.17, after that I am getting below error:

“The connection to server localhost:8080 was refused - did specify the right host or port?”

I also made sure that there is nothing else running on port 8080.

I used ‘snap refresh microk8s -channel=1.17’ to downgrade…

Any help much appreciated

From https://microk8s.io/docs/setting-snap-channel :

Caution: Changing the channel to a different series will almost certainly cause problems, as the configuration from the current version will be retained. If at all possible, it is recommended to re-install MicroK8s rather than refresh to a different channel, as it is not guaranteed to work.

Great! thank you so much sir!! Finally I was able to resolve it by removing microk8s and fresh install.
Thanks again!

1 Like