Linux Mint - Some applications won't start

until today my snap applications were running fine and I was really happy with them. But unfortunately since today I’m unable to run my applications.
I already tried to purge my snapd installaion and reinstalled it. But no success either.

Here’s the output of snap --version:
snap 2.48.3+20.04
snapd 2.48.3+20.04
series 16
linuxmint 20.1
kernel 5.4.0-65-generic

The simple hello-world application is working on snap. But unfortunately applications like rambox, MS Teams for example dont work.

Running for example rambox with the command ‘snap run rambox’ don’t produce an error message or an output.

Running the snap-store or wps-office works on the other hand …

I’m pretty confused and I really don’t know what else I can do, please help.


Hi, the clean up process really needs some better documentation. How to reset my package developement system. This is especially true, if you work on more than one package.
I use myself a script from the forum. This removes ALL layers, downloads from previous sessions.

And this one, but I do not made a research, if it do anything. Just for the sake of completeness:

Hope this helps.

Thanks for the reply!
Not sure what removing all old snap applications helps when even new one’s won’t start.
Nevermind, I tried following both articles - none of them solved my problem.

EDIT: After a day full of researching I finally figured the problem out.
I had a second harddrive symlinked to my Home Directory (as a download folder). Unfortunately that caused the issue. After deleting the symlink every worked as it used to be.
Anyway, thats kind of a strange behaviour.