Latest/Stable version of KeepassXC not working

After upgrading the KeepassXC snap on Ubuntu 20.04 I’m not able to use the application.

In the snap warnings I’ve got the following:

last-occurrence:  today at 11:02 CEST
warning: |
  snap "kde-frameworks-5-102-qt-5-15-8-core22" has bad plugs or slots:
  kde-frameworks-5-102-0+p22-qt-5-15-core22 (invalid slot name:

I saw the same warning on Ubuntu 22.04, but keepassxc version 2.7.5 rev. 1689 latest/stable seems to be working fine in spite of the warning.

Actually it’s pretty strange, because I installed the Latest/Edge version and it works. Now I got back to the Latest/Stable and it works as well. However, having a look at snap warnings, the mentioned warning is not there anymore :face_with_monocle:

The problem is with the KDE snap that KeepassXC pulls in automatically, but it’s not a problem with the KeepassXC snap itself. Since the KDE snap wouldn’t have changed from swapping revisions (since stable/edge are both currently in sync for content snaps), you don’t get the same error since nothing new has happened with the affected snap.

(This means other snaps will also be triggering this warning. The KDE folks should be able to get it sorted!)


Well, I wish I could. That content snap has not changed since February. I cannot rebuild it either. I don’t understand how/why after 4 solid months of usage it is suddenly doing this. I can only hope snapcraft in edge will be released to stable as that will catch up the kde-neon extension to use the newer content packs.

I have solved the issue with:

sudo snap refresh --candidate keepassxc