Keepalived: killall -0 gives an invalid response inside snapd (new version keep alived issue not snapd) [RESOLVED]


#1

Hi all,

i tried to run a keepalived snapd as a floating ip with a loadbalancer cluster
to detect if the loadbalancer is active i use the “killall -0 haproxy”

when i run it without snap it detect that process has stopped
but strangely enough when running keepalived in snapd
the killall -0 haproxy command allways give a true in a sense making the keepalived package not functional anymore

i did install with --classic do i need to do more to allow the killal -0 haproxy command to work?
but also why is it giving a true while the process is not running at all outside or inside snap.


#2

If I’m understanding you properly, keepalived (which is a classic snap) is starting another process, haproxy and you are unable to properly signal the haproxy process using killall?


#3

Hi ijohnson
i found out after i posted that it is actually an keepalived proxy version behavior.

the killall -0 haproxy will give an exit 1 code if the process haproxy is not running

as in the old version you would see in the journal logs that the process is exiting and in the new now i assumed it was an issue in snap somehow not reporting the process was exited.

But the exit notification was moved to the syslog while in the old version it would be in the journal log

after i tested the failovers i reverted back to the snap process as it is working as designed.

Thanks all