Italics text not rendering properly in Firefox 77.0.1-1

I am running Ubuntu 18.04 and use snap to install Firefox, version 77.0.1-1

You’ll see the italic font replaced with those boxes

I noticed that italics text was messed up and not rendering properly. Someone suggested Firefox cannot find any suitable font to display italics for some specific font styles.

I’ve since reloaded my browser and currently italics are loading okay.

1 Like

I have a similar issue on 20.04


This is just a test.

1 Like

Yeah, me too. Restarting Firefox multiple times per day is required and I haven’t yet been able to identify what causes it.

Has anybody experienced this with other snaps? If not, perhaps we should cross-post this to Mozilla’s bug tracker.

LOL I was forced to update to the latest firefox today AND THIS IS STILL NOT FIXED. Having to quit and reopen firefox multiple times a day sucks. Gonna probably switch to qutebrowser instead since there is no action on this that I see.

@leeberto In case you hadn’t come across it already, I no longer get this issue since enabling “refresh app awareness”. You might find it to be a better workaround than switching browsers.

Thanks for posting @_az . I tried that process as well and unfortunately it had absolutely no impact on this issue. My italicized text is still not rendering readably. This was my last straw unfortunately so I’m moving to a different browser.