Issues on unsupported kernel

I use Ubuntu 16.04, but with the latest stable kernel used Ubuntu Kernel Upgrade Utility, which uses the kernels from the
I had something problem, why I started to use fresh kernels, but unfortunately, I do not remember :(.
So, only alone solution to work my apps used snap to back an older kernel?
Is this a snap error or not?

$ snap version
snap 2.28.1
snapd 2.28.1
series 16
ubuntu 16.04
kernel 4.13.7-041307-generic

you are using an untested and unverified kernel, there will be a 4.13 kernel package in the linux-hwe stack eventually, if you stick with linux-hwe everything will work and you do not run your system atop of an untested kernel with potential bugs and security holes … is there any particular reason that you do use this specific test kernel ?

The origin of the problem is complex but it is already fixed in master and will not affect you once 2.29 is released (in about a month).

1 Like

I wrote that I started to use UKUU, because I have some kind of problem (I do not remember it) and it could be solved with a new kernel.
By the way, how can I know that a kernel version is untested, etc? I thought the not rc versions are tested, stable versions.
But, I read about new kernel policy of Ubuntu, and then I will try hwe solution.

Cool, it is a good news :slight_smile:

well, nothing in the official distro will ever offer you such a kernel by default, that is a question you have to ask the maintainer of this third party tool…

IMHO it is a bit irresponsibe that this tool does not pop up a waning that you use an untested development kernel …

yeah, it would be good (if the UKUU showed these important information). But, the hwe solved my problem! :slight_smile: Thx!