Issues core20+colcon+foxy

Hi there,
I’m giving a shot to the update core20+colcon+foxy following kyrofa’s blog post.

When running snapcraft --enable-experimental-extensions with snapcraft snap version 4.1.5.post5+git256bb8de (--edge), I hit the following issue:
launch failed: Unable to find an image matching "core20"
I suppose that’s a multipass version issue? I’m running 1.3.0 (latest/beta). Should I update multipass to a specific version/channel as for snapcraft? The blog post does not mention that.

When using lxd (--use-lxd), it finds core20 fine but fails later on with:
Could not find a required package in 'build-packages': python3-colcon-common-extensions
which looks like the ROS2 sources were not properly added.

Any hint on moving past these issues?

Refreshing multipass to edge (version 1.5.0-dev.43+g95768955) does fix the unknown core20 image issue.
But I do run into the python3-colcon-common-extensions issue too.

Edit:
Ran a clean/re-snap and it is fetching ros-foxy-related packages fine.

I’m having the same problem when running with lxd or multipass. The build stops at:

Could not find a required package in 'build-packages': python3-colcon-common-extensions

I tried snapcraft clean before. But that didnt help. I have snapcraft version 4.3 installed.

I seems like it didn’t add the ROS sources. Right before that the following line appears:

sudo: unable to resolve host ubuntu: Temporary failure in name resolution
snapcraft.yml
name: ros2-pibot-motor-fabolhak
version: '1.3'
summary: ROS2 Motor module for my PiBot
description: |
  This package provides the hardware driver to the PiBots motor. Please read the [Readme](https://github.com/fabolhak/ros2_pibot_motor/blob/master/README.md) for usage instructions.
license: Apache-2.0

confinement: strict
base: core20
grade: devel

parts:
  ros2-motor-driver:
    plugin: colcon
    source: https://github.com/fabolhak/ros2_pibot_motor.git
    source-branch: master
    source-subdir: pibot_motor
    build-packages: [make, gcc, g++]
    stage-packages: [ros-foxy-ros-core]
      
  gpio-lib:
    plugin: python
    python-packages: [RPi.GPIO]

apps:
  run:
    command: opt/ros/foxy/bin/ros2 run ros2_pibot_motor service
    plugs:
       - network
       - network-bind
       - gpio-memory-control
       - hardware-observe

architectures:
  - build-on: arm64
Logs
ubuntu@some-aws-machine:~/ros2_pibot_motor$ snapcraft build --use-lxd --enable-experimental-extensions                                             
*EXPERIMENTAL* extensions enabled.
Launching a container.
Waiting for container to be ready
Created symlink /etc/systemd/system/dbus-org.freedesktop.network1.service → /lib/systemd/system/systemd-networkd.service.
Waiting for network to be ready...
Get:1 http://ports.ubuntu.com/ubuntu-ports focal-security InRelease [107 kB]
Get:2 http://ports.ubuntu.com/ubuntu-ports focal InRelease [265 kB]
Get:3 http://ports.ubuntu.com/ubuntu-ports focal-updates InRelease [111 kB]
Get:4 http://ports.ubuntu.com/ubuntu-ports focal-security/universe Sources [7940 B]
Get:5 http://ports.ubuntu.com/ubuntu-ports focal-security/main Sources [52.4 kB]
Get:6 http://ports.ubuntu.com/ubuntu-ports focal-security/multiverse Sources [716 B]
Get:7 http://ports.ubuntu.com/ubuntu-ports focal-security/restricted Sources [4192 B]
Get:8 http://ports.ubuntu.com/ubuntu-ports focal-security/main arm64 Packages [141 kB]
Get:9 http://ports.ubuntu.com/ubuntu-ports focal-security/main Translation-en [64.5 kB]
Get:10 http://ports.ubuntu.com/ubuntu-ports focal-security/multiverse Translation-en [540 B]
Get:11 http://ports.ubuntu.com/ubuntu-ports focal-security/restricted arm64 Packages [932 B]
Get:12 http://ports.ubuntu.com/ubuntu-ports focal-security/restricted Translation-en [8916 B]
Get:13 http://ports.ubuntu.com/ubuntu-ports focal-security/universe arm64 Packages [52.9 kB]
Get:14 http://ports.ubuntu.com/ubuntu-ports focal-security/universe Translation-en [29.4 kB]
Get:15 http://ports.ubuntu.com/ubuntu-ports focal/restricted Sources [6472 B]
Get:16 http://ports.ubuntu.com/ubuntu-ports focal/universe Sources [9707 kB]
Get:17 http://ports.ubuntu.com/ubuntu-ports focal/multiverse Sources [174 kB]
Get:18 http://ports.ubuntu.com/ubuntu-ports focal/main Sources [847 kB]
Get:19 http://ports.ubuntu.com/ubuntu-ports focal/main arm64 Packages [940 kB]
Get:20 http://ports.ubuntu.com/ubuntu-ports focal/main Translation-en [506 kB]
Get:21 http://ports.ubuntu.com/ubuntu-ports focal/multiverse arm64 Packages [114 kB]
Get:22 http://ports.ubuntu.com/ubuntu-ports focal/multiverse Translation-en [104 kB]
Get:23 http://ports.ubuntu.com/ubuntu-ports focal/restricted arm64 Packages [1300 B]
Get:24 http://ports.ubuntu.com/ubuntu-ports focal/restricted Translation-en [6212 B]
Get:25 http://ports.ubuntu.com/ubuntu-ports focal/universe arm64 Packages [8458 kB]
Get:26 http://ports.ubuntu.com/ubuntu-ports focal/universe Translation-en [5124 kB]
Get:27 http://ports.ubuntu.com/ubuntu-ports focal-updates/main Sources [181 kB]
Get:28 http://ports.ubuntu.com/ubuntu-ports focal-updates/restricted Sources [4188 B]
Get:29 http://ports.ubuntu.com/ubuntu-ports focal-updates/multiverse Sources [4620 B]
Get:30 http://ports.ubuntu.com/ubuntu-ports focal-updates/universe Sources [57.2 kB]
Get:31 http://ports.ubuntu.com/ubuntu-ports focal-updates/main arm64 Packages [309 kB]
Get:32 http://ports.ubuntu.com/ubuntu-ports focal-updates/main Translation-en [133 kB]
Get:33 http://ports.ubuntu.com/ubuntu-ports focal-updates/multiverse arm64 Packages [2260 B]
Get:34 http://ports.ubuntu.com/ubuntu-ports focal-updates/multiverse Translation-en [3892 B]
Get:35 http://ports.ubuntu.com/ubuntu-ports focal-updates/restricted arm64 Packages [932 B]
Get:36 http://ports.ubuntu.com/ubuntu-ports focal-updates/restricted Translation-en [8968 B]
Get:37 http://ports.ubuntu.com/ubuntu-ports focal-updates/universe arm64 Packages [160 kB]
Get:38 http://ports.ubuntu.com/ubuntu-ports focal-updates/universe Translation-en [87.1 kB]
Fetched 27.8 MB in 6s (4390 kB/s)                                                                                                                                                                                                         
Reading package lists... Done
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following additional packages will be installed:
  libasn1-8-heimdal libfuse2 libgssapi3-heimdal libhcrypto4-heimdal libheimbase1-heimdal libheimntlm0-heimdal libhx509-5-heimdal libkrb5-26-heimdal libksba8 libldap-2.4-2 libldap-common libroken18-heimdal libsasl2-2
  libsasl2-modules-db libudev1 libwind0-heimdal
Suggested packages:
  dbus-user-session libpam-systemd pinentry-gnome3 tor
Recommended packages:
  gnupg libsasl2-modules
The following NEW packages will be installed:
  dirmngr fuse libasn1-8-heimdal libfuse2 libgssapi3-heimdal libhcrypto4-heimdal libheimbase1-heimdal libheimntlm0-heimdal libhx509-5-heimdal libkrb5-26-heimdal libksba8 libldap-2.4-2 libldap-common libroken18-heimdal libsasl2-2
  libsasl2-modules-db libwind0-heimdal udev
The following packages will be upgraded:
  libudev1
1 upgraded, 18 newly installed, 0 to remove and 24 not upgraded.
Need to get 2847 kB of archives.
After this operation, 14.5 MB of additional disk space will be used.
Get:1 http://ports.ubuntu.com/ubuntu-ports focal-updates/main arm64 libudev1 arm64 245.4-4ubuntu3.2 [72.7 kB]
Get:2 http://ports.ubuntu.com/ubuntu-ports focal-updates/main arm64 udev arm64 245.4-4ubuntu3.2 [1315 kB]
Get:3 http://ports.ubuntu.com/ubuntu-ports focal/main arm64 libfuse2 arm64 2.9.9-3 [76.8 kB]
Get:4 http://ports.ubuntu.com/ubuntu-ports focal/main arm64 fuse arm64 2.9.9-3 [24.6 kB]
Get:5 http://ports.ubuntu.com/ubuntu-ports focal/main arm64 libksba8 arm64 1.3.5-2 [77.4 kB]
Get:6 http://ports.ubuntu.com/ubuntu-ports focal/main arm64 libroken18-heimdal arm64 7.7.0+dfsg-1ubuntu1 [39.4 kB]
Get:7 http://ports.ubuntu.com/ubuntu-ports focal/main arm64 libasn1-8-heimdal arm64 7.7.0+dfsg-1ubuntu1 [150 kB]
Get:8 http://ports.ubuntu.com/ubuntu-ports focal/main arm64 libheimbase1-heimdal arm64 7.7.0+dfsg-1ubuntu1 [27.9 kB]
Get:9 http://ports.ubuntu.com/ubuntu-ports focal/main arm64 libhcrypto4-heimdal arm64 7.7.0+dfsg-1ubuntu1 [86.4 kB]
Get:10 http://ports.ubuntu.com/ubuntu-ports focal/main arm64 libwind0-heimdal arm64 7.7.0+dfsg-1ubuntu1 [47.3 kB]
Get:11 http://ports.ubuntu.com/ubuntu-ports focal/main arm64 libhx509-5-heimdal arm64 7.7.0+dfsg-1ubuntu1 [98.7 kB]
Get:12 http://ports.ubuntu.com/ubuntu-ports focal/main arm64 libkrb5-26-heimdal arm64 7.7.0+dfsg-1ubuntu1 [191 kB]
Get:13 http://ports.ubuntu.com/ubuntu-ports focal/main arm64 libheimntlm0-heimdal arm64 7.7.0+dfsg-1ubuntu1 [14.7 kB]
Get:14 http://ports.ubuntu.com/ubuntu-ports focal/main arm64 libgssapi3-heimdal arm64 7.7.0+dfsg-1ubuntu1 [88.3 kB]
Get:15 http://ports.ubuntu.com/ubuntu-ports focal/main arm64 libsasl2-modules-db arm64 2.1.27+dfsg-2 [15.1 kB]
Get:16 http://ports.ubuntu.com/ubuntu-ports focal/main arm64 libsasl2-2 arm64 2.1.27+dfsg-2 [48.4 kB]
Get:17 http://ports.ubuntu.com/ubuntu-ports focal-updates/main arm64 libldap-common all 2.4.49+dfsg-2ubuntu1.3 [17.0 kB]
Get:18 http://ports.ubuntu.com/ubuntu-ports focal-updates/main arm64 libldap-2.4-2 arm64 2.4.49+dfsg-2ubuntu1.3 [145 kB]
Get:19 http://ports.ubuntu.com/ubuntu-ports focal/main arm64 dirmngr arm64 2.2.19-3ubuntu2 [311 kB]
Fetched 2847 kB in 0s (11.8 MB/s)
debconf: delaying package configuration, since apt-utils is not installed
(Reading database ... 12809 files and directories currently installed.)
Preparing to unpack .../libudev1_245.4-4ubuntu3.2_arm64.deb ...
Unpacking libudev1:arm64 (245.4-4ubuntu3.2) over (245.4-4ubuntu3) ...
Setting up libudev1:arm64 (245.4-4ubuntu3.2) ...
Selecting previously unselected package udev.
(Reading database ... 12809 files and directories currently installed.)
Preparing to unpack .../00-udev_245.4-4ubuntu3.2_arm64.deb ...
Unpacking udev (245.4-4ubuntu3.2) ...
Selecting previously unselected package libfuse2:arm64.
Preparing to unpack .../01-libfuse2_2.9.9-3_arm64.deb ...
Unpacking libfuse2:arm64 (2.9.9-3) ...
Selecting previously unselected package fuse.
Preparing to unpack .../02-fuse_2.9.9-3_arm64.deb ...
Unpacking fuse (2.9.9-3) ...
Selecting previously unselected package libksba8:arm64.
Preparing to unpack .../03-libksba8_1.3.5-2_arm64.deb ...
Unpacking libksba8:arm64 (1.3.5-2) ...
Selecting previously unselected package libroken18-heimdal:arm64.
Preparing to unpack .../04-libroken18-heimdal_7.7.0+dfsg-1ubuntu1_arm64.deb ...
Unpacking libroken18-heimdal:arm64 (7.7.0+dfsg-1ubuntu1) ...
Selecting previously unselected package libasn1-8-heimdal:arm64.
Preparing to unpack .../05-libasn1-8-heimdal_7.7.0+dfsg-1ubuntu1_arm64.deb ...
Unpacking libasn1-8-heimdal:arm64 (7.7.0+dfsg-1ubuntu1) ...
Selecting previously unselected package libheimbase1-heimdal:arm64.
Preparing to unpack .../06-libheimbase1-heimdal_7.7.0+dfsg-1ubuntu1_arm64.deb ...
Unpacking libheimbase1-heimdal:arm64 (7.7.0+dfsg-1ubuntu1) ...
Selecting previously unselected package libhcrypto4-heimdal:arm64.
Preparing to unpack .../07-libhcrypto4-heimdal_7.7.0+dfsg-1ubuntu1_arm64.deb ...
Unpacking libhcrypto4-heimdal:arm64 (7.7.0+dfsg-1ubuntu1) ...
Selecting previously unselected package libwind0-heimdal:arm64.
Preparing to unpack .../08-libwind0-heimdal_7.7.0+dfsg-1ubuntu1_arm64.deb ...
Unpacking libwind0-heimdal:arm64 (7.7.0+dfsg-1ubuntu1) ...
Selecting previously unselected package libhx509-5-heimdal:arm64.
Preparing to unpack .../09-libhx509-5-heimdal_7.7.0+dfsg-1ubuntu1_arm64.deb ...
Unpacking libhx509-5-heimdal:arm64 (7.7.0+dfsg-1ubuntu1) ...
Selecting previously unselected package libkrb5-26-heimdal:arm64.
Preparing to unpack .../10-libkrb5-26-heimdal_7.7.0+dfsg-1ubuntu1_arm64.deb ...
Unpacking libkrb5-26-heimdal:arm64 (7.7.0+dfsg-1ubuntu1) ...
Selecting previously unselected package libheimntlm0-heimdal:arm64.
Preparing to unpack .../11-libheimntlm0-heimdal_7.7.0+dfsg-1ubuntu1_arm64.deb ...
Unpacking libheimntlm0-heimdal:arm64 (7.7.0+dfsg-1ubuntu1) ...
Selecting previously unselected package libgssapi3-heimdal:arm64.
Preparing to unpack .../12-libgssapi3-heimdal_7.7.0+dfsg-1ubuntu1_arm64.deb ...
Unpacking libgssapi3-heimdal:arm64 (7.7.0+dfsg-1ubuntu1) ...
Selecting previously unselected package libsasl2-modules-db:arm64.
Preparing to unpack .../13-libsasl2-modules-db_2.1.27+dfsg-2_arm64.deb ...
Unpacking libsasl2-modules-db:arm64 (2.1.27+dfsg-2) ...
Selecting previously unselected package libsasl2-2:arm64.
Preparing to unpack .../14-libsasl2-2_2.1.27+dfsg-2_arm64.deb ...
Unpacking libsasl2-2:arm64 (2.1.27+dfsg-2) ...
Selecting previously unselected package libldap-common.
Preparing to unpack .../15-libldap-common_2.4.49+dfsg-2ubuntu1.3_all.deb ...
Unpacking libldap-common (2.4.49+dfsg-2ubuntu1.3) ...
Selecting previously unselected package libldap-2.4-2:arm64.
Preparing to unpack .../16-libldap-2.4-2_2.4.49+dfsg-2ubuntu1.3_arm64.deb ...
Unpacking libldap-2.4-2:arm64 (2.4.49+dfsg-2ubuntu1.3) ...
Selecting previously unselected package dirmngr.
Preparing to unpack .../17-dirmngr_2.2.19-3ubuntu2_arm64.deb ...
Unpacking dirmngr (2.2.19-3ubuntu2) ...
Setting up libksba8:arm64 (1.3.5-2) ...
Setting up libfuse2:arm64 (2.9.9-3) ...
Setting up libldap-common (2.4.49+dfsg-2ubuntu1.3) ...
Setting up libsasl2-modules-db:arm64 (2.1.27+dfsg-2) ...
Setting up udev (245.4-4ubuntu3.2) ...
invoke-rc.d: policy-rc.d denied execution of start.
Setting up libsasl2-2:arm64 (2.1.27+dfsg-2) ...
Setting up libroken18-heimdal:arm64 (7.7.0+dfsg-1ubuntu1) ...
Setting up libheimbase1-heimdal:arm64 (7.7.0+dfsg-1ubuntu1) ...
Setting up fuse (2.9.9-3) ...
Setting up libasn1-8-heimdal:arm64 (7.7.0+dfsg-1ubuntu1) ...
Setting up libhcrypto4-heimdal:arm64 (7.7.0+dfsg-1ubuntu1) ...
Setting up libwind0-heimdal:arm64 (7.7.0+dfsg-1ubuntu1) ...
Setting up libhx509-5-heimdal:arm64 (7.7.0+dfsg-1ubuntu1) ...
Setting up libkrb5-26-heimdal:arm64 (7.7.0+dfsg-1ubuntu1) ...
Setting up libheimntlm0-heimdal:arm64 (7.7.0+dfsg-1ubuntu1) ...
Setting up libgssapi3-heimdal:arm64 (7.7.0+dfsg-1ubuntu1) ...
Setting up libldap-2.4-2:arm64 (2.4.49+dfsg-2ubuntu1.3) ...
Setting up dirmngr (2.2.19-3ubuntu2) ...
Created symlink /etc/systemd/user/sockets.target.wants/dirmngr.socket → /usr/lib/systemd/user/dirmngr.socket.
Processing triggers for systemd (245.4-4ubuntu3) ...
Processing triggers for libc-bin (2.31-0ubuntu9) ...
The unit files have no installation config (WantedBy=, RequiredBy=, Also=,
Alias= settings in the [Install] section, and DefaultInstance= for template
units). This means they are not meant to be enabled using systemctl.
 
Possible reasons for having this kind of units are:
• A unit may be statically enabled by being symlinked from another unit's
  .wants/ or .requires/ directory.
• A unit's purpose may be to act as a helper for some other unit which has
  a requirement dependency on it.
• A unit may be started when needed via activation (socket, path, timer,
  D-Bus, udev, scripted systemctl call, ...).
• In case of template units, the unit is meant to be enabled with some
  instance name specified.
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following additional packages will be installed:
  apparmor libbsd0 libcbor0.6 libedit2 libexpat1 libfido2-1 libgssapi-krb5-2 libk5crypto3 libkeyutils1 libkrb5-3 libkrb5support0 liblzo2-2 libmpdec2 libpython3-stdlib libpython3.8-minimal libpython3.8-stdlib mime-support
  openssh-client python3 python3-minimal python3.8 python3.8-minimal squashfs-tools
Suggested packages:
  apparmor-profiles-extra apparmor-utils krb5-doc krb5-user keychain libpam-ssh monkeysphere ssh-askpass python3-doc python3-tk python3-venv python3.8-venv python3.8-doc binfmt-support zenity | kdialog
Recommended packages:
  krb5-locales file xauth gnupg
The following NEW packages will be installed:
  apparmor libbsd0 libcbor0.6 libedit2 libexpat1 libfido2-1 libgssapi-krb5-2 libk5crypto3 libkeyutils1 libkrb5-3 libkrb5support0 liblzo2-2 libmpdec2 libpython3-stdlib libpython3.8-minimal libpython3.8-stdlib mime-support
  openssh-client python3 python3-minimal python3.8 python3.8-minimal snapd squashfs-tools sudo
0 upgraded, 25 newly installed, 0 to remove and 24 not upgraded.
Need to get 31.5 MB of archives.
After this operation, 145 MB of additional disk space will be used.
Get:1 http://ports.ubuntu.com/ubuntu-ports focal-security/main arm64 libpython3.8-minimal arm64 3.8.2-1ubuntu1.2 [702 kB]
Get:2 http://ports.ubuntu.com/ubuntu-ports focal/main arm64 libexpat1 arm64 2.2.9-1build1 [61.3 kB]
Get:3 http://ports.ubuntu.com/ubuntu-ports focal-security/main arm64 python3.8-minimal arm64 3.8.2-1ubuntu1.2 [1828 kB]
Get:4 http://ports.ubuntu.com/ubuntu-ports focal/main arm64 python3-minimal arm64 3.8.2-0ubuntu2 [23.6 kB]
Get:5 http://ports.ubuntu.com/ubuntu-ports focal/main arm64 mime-support all 3.64ubuntu1 [30.6 kB]
Get:6 http://ports.ubuntu.com/ubuntu-ports focal/main arm64 libmpdec2 arm64 2.4.2-3 [79.6 kB]
Get:7 http://ports.ubuntu.com/ubuntu-ports focal-security/main arm64 libpython3.8-stdlib arm64 3.8.2-1ubuntu1.2 [1641 kB]
Get:8 http://ports.ubuntu.com/ubuntu-ports focal-security/main arm64 python3.8 arm64 3.8.2-1ubuntu1.2 [364 kB]
Get:9 http://ports.ubuntu.com/ubuntu-ports focal/main arm64 libpython3-stdlib arm64 3.8.2-0ubuntu2 [7068 B]
Get:10 http://ports.ubuntu.com/ubuntu-ports focal/main arm64 python3 arm64 3.8.2-0ubuntu2 [47.6 kB]
Get:11 http://ports.ubuntu.com/ubuntu-ports focal/main arm64 libbsd0 arm64 0.10.0-1 [43.7 kB]
Get:12 http://ports.ubuntu.com/ubuntu-ports focal-updates/main arm64 sudo arm64 1.8.31-1ubuntu1.1 [473 kB]
Get:13 http://ports.ubuntu.com/ubuntu-ports focal-updates/main arm64 apparmor arm64 2.13.3-7ubuntu5.1 [455 kB]
Get:14 http://ports.ubuntu.com/ubuntu-ports focal/main arm64 libcbor0.6 arm64 0.6.0-0ubuntu1 [20.5 kB]
Get:15 http://ports.ubuntu.com/ubuntu-ports focal/main arm64 libedit2 arm64 3.1-20191231-1 [82.7 kB]
Get:16 http://ports.ubuntu.com/ubuntu-ports focal/main arm64 libfido2-1 arm64 1.3.1-1ubuntu2 [45.1 kB]
Get:17 http://ports.ubuntu.com/ubuntu-ports focal/main arm64 libkrb5support0 arm64 1.17-6ubuntu4 [30.4 kB]
Get:18 http://ports.ubuntu.com/ubuntu-ports focal/main arm64 libk5crypto3 arm64 1.17-6ubuntu4 [80.5 kB]
Get:19 http://ports.ubuntu.com/ubuntu-ports focal/main arm64 libkeyutils1 arm64 1.6-6ubuntu1 [10.1 kB]
Get:20 http://ports.ubuntu.com/ubuntu-ports focal/main arm64 libkrb5-3 arm64 1.17-6ubuntu4 [312 kB]
Get:21 http://ports.ubuntu.com/ubuntu-ports focal/main arm64 libgssapi-krb5-2 arm64 1.17-6ubuntu4 [113 kB]
Get:22 http://ports.ubuntu.com/ubuntu-ports focal-updates/main arm64 openssh-client arm64 1:8.2p1-4ubuntu0.1 [640 kB]
Get:23 http://ports.ubuntu.com/ubuntu-ports focal/main arm64 liblzo2-2 arm64 2.10-2 [45.5 kB]
Get:24 http://ports.ubuntu.com/ubuntu-ports focal/main arm64 squashfs-tools arm64 1:4.4-1 [115 kB]
Get:25 http://ports.ubuntu.com/ubuntu-ports focal-security/main arm64 snapd arm64 2.45.1+20.04.2 [24.2 MB]
Fetched 31.5 MB in 1s (39.1 MB/s)
debconf: delaying package configuration, since apt-utils is not installed
Selecting previously unselected package libpython3.8-minimal:arm64.
(Reading database ... 13059 files and directories currently installed.)
Preparing to unpack .../libpython3.8-minimal_3.8.2-1ubuntu1.2_arm64.deb ...
Unpacking libpython3.8-minimal:arm64 (3.8.2-1ubuntu1.2) ...
Selecting previously unselected package libexpat1:arm64.
Preparing to unpack .../libexpat1_2.2.9-1build1_arm64.deb ...
Unpacking libexpat1:arm64 (2.2.9-1build1) ...
Selecting previously unselected package python3.8-minimal.
Preparing to unpack .../python3.8-minimal_3.8.2-1ubuntu1.2_arm64.deb ...
Unpacking python3.8-minimal (3.8.2-1ubuntu1.2) ...
Setting up libpython3.8-minimal:arm64 (3.8.2-1ubuntu1.2) ...
Setting up libexpat1:arm64 (2.2.9-1build1) ...
Setting up python3.8-minimal (3.8.2-1ubuntu1.2) ...
Selecting previously unselected package python3-minimal.
(Reading database ... 13350 files and directories currently installed.)
Preparing to unpack .../0-python3-minimal_3.8.2-0ubuntu2_arm64.deb ...
Unpacking python3-minimal (3.8.2-0ubuntu2) ...
Selecting previously unselected package mime-support.
Preparing to unpack .../1-mime-support_3.64ubuntu1_all.deb ...
Unpacking mime-support (3.64ubuntu1) ...
Selecting previously unselected package libmpdec2:arm64.
Preparing to unpack .../2-libmpdec2_2.4.2-3_arm64.deb ...
Unpacking libmpdec2:arm64 (2.4.2-3) ...
Selecting previously unselected package libpython3.8-stdlib:arm64.
Preparing to unpack .../3-libpython3.8-stdlib_3.8.2-1ubuntu1.2_arm64.deb ...
Unpacking libpython3.8-stdlib:arm64 (3.8.2-1ubuntu1.2) ...
Selecting previously unselected package python3.8.
Preparing to unpack .../4-python3.8_3.8.2-1ubuntu1.2_arm64.deb ...
Unpacking python3.8 (3.8.2-1ubuntu1.2) ...
Selecting previously unselected package libpython3-stdlib:arm64.
Preparing to unpack .../5-libpython3-stdlib_3.8.2-0ubuntu2_arm64.deb ...
Unpacking libpython3-stdlib:arm64 (3.8.2-0ubuntu2) ...
Setting up python3-minimal (3.8.2-0ubuntu2) ...
Selecting previously unselected package python3.
(Reading database ... 13752 files and directories currently installed.)
Preparing to unpack .../00-python3_3.8.2-0ubuntu2_arm64.deb ...
Unpacking python3 (3.8.2-0ubuntu2) ...
Selecting previously unselected package libbsd0:arm64.
Preparing to unpack .../01-libbsd0_0.10.0-1_arm64.deb ...
Unpacking libbsd0:arm64 (0.10.0-1) ...
Selecting previously unselected package sudo.
Preparing to unpack .../02-sudo_1.8.31-1ubuntu1.1_arm64.deb ...
Unpacking sudo (1.8.31-1ubuntu1.1) ...
Selecting previously unselected package apparmor.
Preparing to unpack .../03-apparmor_2.13.3-7ubuntu5.1_arm64.deb ...
Unpacking apparmor (2.13.3-7ubuntu5.1) ...
Selecting previously unselected package libcbor0.6:arm64.
Preparing to unpack .../04-libcbor0.6_0.6.0-0ubuntu1_arm64.deb ...
Unpacking libcbor0.6:arm64 (0.6.0-0ubuntu1) ...
Selecting previously unselected package libedit2:arm64.
Preparing to unpack .../05-libedit2_3.1-20191231-1_arm64.deb ...
Unpacking libedit2:arm64 (3.1-20191231-1) ...
Selecting previously unselected package libfido2-1:arm64.
Preparing to unpack .../06-libfido2-1_1.3.1-1ubuntu2_arm64.deb ...
Unpacking libfido2-1:arm64 (1.3.1-1ubuntu2) ...
Selecting previously unselected package libkrb5support0:arm64.
Preparing to unpack .../07-libkrb5support0_1.17-6ubuntu4_arm64.deb ...
Unpacking libkrb5support0:arm64 (1.17-6ubuntu4) ...
Selecting previously unselected package libk5crypto3:arm64.
Preparing to unpack .../08-libk5crypto3_1.17-6ubuntu4_arm64.deb ...
Unpacking libk5crypto3:arm64 (1.17-6ubuntu4) ...
Selecting previously unselected package libkeyutils1:arm64.
Preparing to unpack .../09-libkeyutils1_1.6-6ubuntu1_arm64.deb ...
Unpacking libkeyutils1:arm64 (1.6-6ubuntu1) ...
Selecting previously unselected package libkrb5-3:arm64.
Preparing to unpack .../10-libkrb5-3_1.17-6ubuntu4_arm64.deb ...
Unpacking libkrb5-3:arm64 (1.17-6ubuntu4) ...
Selecting previously unselected package libgssapi-krb5-2:arm64.
Preparing to unpack .../11-libgssapi-krb5-2_1.17-6ubuntu4_arm64.deb ...
Unpacking libgssapi-krb5-2:arm64 (1.17-6ubuntu4) ...
Selecting previously unselected package openssh-client.
Preparing to unpack .../12-openssh-client_1%3a8.2p1-4ubuntu0.1_arm64.deb ...
Unpacking openssh-client (1:8.2p1-4ubuntu0.1) ...
Selecting previously unselected package liblzo2-2:arm64.
Preparing to unpack .../13-liblzo2-2_2.10-2_arm64.deb ...
Unpacking liblzo2-2:arm64 (2.10-2) ...
Selecting previously unselected package squashfs-tools.
Preparing to unpack .../14-squashfs-tools_1%3a4.4-1_arm64.deb ...
Unpacking squashfs-tools (1:4.4-1) ...
Selecting previously unselected package snapd.
Preparing to unpack .../15-snapd_2.45.1+20.04.2_arm64.deb ...
Unpacking snapd (2.45.1+20.04.2) ...
Setting up libkeyutils1:arm64 (1.6-6ubuntu1) ...
Setting up mime-support (3.64ubuntu1) ...
Setting up liblzo2-2:arm64 (2.10-2) ...
Setting up libcbor0.6:arm64 (0.6.0-0ubuntu1) ...
Setting up libkrb5support0:arm64 (1.17-6ubuntu4) ...
Setting up sudo (1.8.31-1ubuntu1.1) ...
Setting up libk5crypto3:arm64 (1.17-6ubuntu4) ...
Setting up libkrb5-3:arm64 (1.17-6ubuntu4) ...
Setting up libmpdec2:arm64 (2.4.2-3) ...
Setting up libpython3.8-stdlib:arm64 (3.8.2-1ubuntu1.2) ...
Setting up libfido2-1:arm64 (1.3.1-1ubuntu2) ...
Setting up python3.8 (3.8.2-1ubuntu1.2) ...
Setting up libbsd0:arm64 (0.10.0-1) ...
Setting up libpython3-stdlib:arm64 (3.8.2-0ubuntu2) ...
Setting up squashfs-tools (1:4.4-1) ...
Setting up libedit2:arm64 (3.1-20191231-1) ...
Setting up python3 (3.8.2-0ubuntu2) ...
running python rtupdate hooks for python3.8...
running python post-rtupdate hooks for python3.8...
Setting up apparmor (2.13.3-7ubuntu5.1) ...
Created symlink /etc/systemd/system/sysinit.target.wants/apparmor.service → /lib/systemd/system/apparmor.service.
Reloading AppArmor profiles 
Setting up libgssapi-krb5-2:arm64 (1.17-6ubuntu4) ...
Setting up openssh-client (1:8.2p1-4ubuntu0.1) ...
Setting up snapd (2.45.1+20.04.2) ...
Created symlink /etc/systemd/system/multi-user.target.wants/snapd.apparmor.service → /lib/systemd/system/snapd.apparmor.service.
Created symlink /etc/systemd/system/multi-user.target.wants/snapd.autoimport.service → /lib/systemd/system/snapd.autoimport.service.
Created symlink /etc/systemd/system/multi-user.target.wants/snapd.core-fixup.service → /lib/systemd/system/snapd.core-fixup.service.
Created symlink /etc/systemd/system/multi-user.target.wants/snapd.recovery-chooser-trigger.service → /lib/systemd/system/snapd.recovery-chooser-trigger.service.
Created symlink /etc/systemd/system/multi-user.target.wants/snapd.seeded.service → /lib/systemd/system/snapd.seeded.service.
Created symlink /etc/systemd/system/cloud-final.service.wants/snapd.seeded.service → /lib/systemd/system/snapd.seeded.service.
Created symlink /etc/systemd/system/multi-user.target.wants/snapd.service → /lib/systemd/system/snapd.service.
Created symlink /etc/systemd/system/timers.target.wants/snapd.snap-repair.timer → /lib/systemd/system/snapd.snap-repair.timer.
Created symlink /etc/systemd/system/sockets.target.wants/snapd.socket → /lib/systemd/system/snapd.socket.
Created symlink /etc/systemd/system/final.target.wants/snapd.system-shutdown.service → /lib/systemd/system/snapd.system-shutdown.service.
/usr/sbin/policy-rc.d returned 101, not running 'start snapd.apparmor.service snapd.autoimport.service snapd.core-fixup.service snapd.failure.service snapd.recovery-chooser-trigger.service snapd.seeded.service snapd.service snapd.snap-repair.service snapd.snap-repair.timer snapd.socket snapd.system-shutdown.service'
Processing triggers for systemd (245.4-4ubuntu3) ...
Processing triggers for libc-bin (2.31-0ubuntu9) ...
Hit:1 http://ports.ubuntu.com/ubuntu-ports focal-security InRelease
Hit:2 http://ports.ubuntu.com/ubuntu-ports focal InRelease
Hit:3 http://ports.ubuntu.com/ubuntu-ports focal-updates InRelease
Reading package lists... Done
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Calculating upgrade... Done
The following packages will be upgraded:
  apt base-files bash ca-certificates libapparmor1 libapt-pkg6.0 libgnutls30 libjson-c4 liblzma5 libpam-modules libpam-modules-bin libpam-runtime libpam0g libseccomp2 libsqlite3-0 libsystemd0 linux-libc-dev login passwd systemd
  systemd-sysv systemd-timesyncd tzdata xz-utils
24 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Need to get 10.9 MB of archives.
After this operation, 76.8 kB of additional disk space will be used.
Get:1 http://ports.ubuntu.com/ubuntu-ports focal-updates/main arm64 base-files arm64 11ubuntu5.2 [60.5 kB]
Get:2 http://ports.ubuntu.com/ubuntu-ports focal-updates/main arm64 bash arm64 5.0-6ubuntu1.1 [604 kB]
Get:3 http://ports.ubuntu.com/ubuntu-ports focal-updates/main arm64 login arm64 1:4.8.1-1ubuntu5.20.04 [218 kB]
Get:4 http://ports.ubuntu.com/ubuntu-ports focal-updates/main arm64 liblzma5 arm64 5.2.4-1ubuntu1 [87.9 kB]
Get:5 http://ports.ubuntu.com/ubuntu-ports focal-updates/main arm64 systemd-timesyncd arm64 245.4-4ubuntu3.2 [26.3 kB]
Get:6 http://ports.ubuntu.com/ubuntu-ports focal-updates/main arm64 systemd-sysv arm64 245.4-4ubuntu3.2 [10.3 kB]
Get:7 http://ports.ubuntu.com/ubuntu-ports focal-updates/main arm64 libapparmor1 arm64 2.13.3-7ubuntu5.1 [32.9 kB]
Get:8 http://ports.ubuntu.com/ubuntu-ports focal-security/main arm64 libgnutls30 arm64 3.6.13-2ubuntu1.3 [753 kB]
Get:9 http://ports.ubuntu.com/ubuntu-ports focal-updates/main arm64 libpam0g arm64 1.3.1-5ubuntu4.1 [53.9 kB]
Get:10 http://ports.ubuntu.com/ubuntu-ports focal-security/main arm64 libseccomp2 arm64 2.4.3-1ubuntu3.20.04.3 [40.1 kB]
Get:11 http://ports.ubuntu.com/ubuntu-ports focal-updates/main arm64 systemd arm64 245.4-4ubuntu3.2 [3488 kB]
Get:12 http://ports.ubuntu.com/ubuntu-ports focal-updates/main arm64 libsystemd0 arm64 245.4-4ubuntu3.2 [250 kB]
Get:13 http://ports.ubuntu.com/ubuntu-ports focal-security/main arm64 libapt-pkg6.0 arm64 2.0.2ubuntu0.1 [757 kB]
Get:14 http://ports.ubuntu.com/ubuntu-ports focal-security/main arm64 apt arm64 2.0.2ubuntu0.1 [1240 kB]
Get:15 http://ports.ubuntu.com/ubuntu-ports focal-updates/main arm64 libpam-modules-bin arm64 1.3.1-5ubuntu4.1 [35.9 kB]
Get:16 http://ports.ubuntu.com/ubuntu-ports focal-updates/main arm64 libpam-modules arm64 1.3.1-5ubuntu4.1 [242 kB]
Get:17 http://ports.ubuntu.com/ubuntu-ports focal-updates/main arm64 libpam-runtime all 1.3.1-5ubuntu4.1 [37.3 kB]
Get:18 http://ports.ubuntu.com/ubuntu-ports focal-updates/main arm64 passwd arm64 1:4.8.1-1ubuntu5.20.04 [770 kB]
Get:19 http://ports.ubuntu.com/ubuntu-ports focal-security/main arm64 ca-certificates all 20190110ubuntu1.1 [145 kB]
Get:20 http://ports.ubuntu.com/ubuntu-ports focal-security/main arm64 libjson-c4 arm64 0.13.1+dfsg-7ubuntu0.3 [28.3 kB]
Get:21 http://ports.ubuntu.com/ubuntu-ports focal-security/main arm64 libsqlite3-0 arm64 3.31.1-4ubuntu0.2 [507 kB]
Get:22 http://ports.ubuntu.com/ubuntu-ports focal-security/main arm64 tzdata all 2020a-0ubuntu0.20.04 [293 kB]
Get:23 http://ports.ubuntu.com/ubuntu-ports focal-updates/main arm64 xz-utils arm64 5.2.4-1ubuntu1 [81.2 kB]
Get:24 http://ports.ubuntu.com/ubuntu-ports focal-security/main arm64 linux-libc-dev arm64 5.4.0-47.51 [1117 kB]
Fetched 10.9 MB in 0s (26.9 MB/s)     
debconf: delaying package configuration, since apt-utils is not installed
(Reading database ... 14226 files and directories currently installed.)
Preparing to unpack .../base-files_11ubuntu5.2_arm64.deb ...
/usr/sbin/policy-rc.d returned 101, not running 'stop motd-news.service'
/usr/sbin/policy-rc.d returned 101, not running 'stop motd-news.timer'
Unpacking base-files (11ubuntu5.2) over (11ubuntu5) ...
Setting up base-files (11ubuntu5.2) ...
Installing new version of config file /etc/issue ...
Installing new version of config file /etc/issue.net ...
Installing new version of config file /etc/lsb-release ...
Installing new version of config file /etc/update-motd.d/50-motd-news ...
/usr/sbin/policy-rc.d returned 101, not running 'start motd-news.timer'
/usr/sbin/policy-rc.d returned 101, not running 'start motd-news.service'
Removing obsolete conffile /etc/default/motd-news ...
(Reading database ... 14225 files and directories currently installed.)
Preparing to unpack .../bash_5.0-6ubuntu1.1_arm64.deb ...
Unpacking bash (5.0-6ubuntu1.1) over (5.0-6ubuntu1) ...
Setting up bash (5.0-6ubuntu1.1) ...
update-alternatives: using /usr/share/man/man7/bash-builtins.7.gz to provide /usr/share/man/man7/builtins.7.gz (builtins.7.gz) in auto mode
(Reading database ... 14225 files and directories currently installed.)
Preparing to unpack .../login_1%3a4.8.1-1ubuntu5.20.04_arm64.deb ...
Unpacking login (1:4.8.1-1ubuntu5.20.04) over (1:4.8.1-1ubuntu5) ...
Setting up login (1:4.8.1-1ubuntu5.20.04) ...
(Reading database ... 14225 files and directories currently installed.)
Preparing to unpack .../liblzma5_5.2.4-1ubuntu1_arm64.deb ...
Unpacking liblzma5:arm64 (5.2.4-1ubuntu1) over (5.2.4-1) ...
Setting up liblzma5:arm64 (5.2.4-1ubuntu1) ...
(Reading database ... 14225 files and directories currently installed.)
Preparing to unpack .../systemd-timesyncd_245.4-4ubuntu3.2_arm64.deb ...
Unpacking systemd-timesyncd (245.4-4ubuntu3.2) over (245.4-4ubuntu3) ...
Preparing to unpack .../systemd-sysv_245.4-4ubuntu3.2_arm64.deb ...
Unpacking systemd-sysv (245.4-4ubuntu3.2) over (245.4-4ubuntu3) ...
Preparing to unpack .../libapparmor1_2.13.3-7ubuntu5.1_arm64.deb ...
Unpacking libapparmor1:arm64 (2.13.3-7ubuntu5.1) over (2.13.3-7ubuntu5) ...
Preparing to unpack .../libgnutls30_3.6.13-2ubuntu1.3_arm64.deb ...
Unpacking libgnutls30:arm64 (3.6.13-2ubuntu1.3) over (3.6.13-2ubuntu1) ...
Setting up libgnutls30:arm64 (3.6.13-2ubuntu1.3) ...
(Reading database ... 14225 files and directories currently installed.)
Preparing to unpack .../libpam0g_1.3.1-5ubuntu4.1_arm64.deb ...
Unpacking libpam0g:arm64 (1.3.1-5ubuntu4.1) over (1.3.1-5ubuntu4) ...
Setting up libpam0g:arm64 (1.3.1-5ubuntu4.1) ...
(Reading database ... 14225 files and directories currently installed.)
Preparing to unpack .../libseccomp2_2.4.3-1ubuntu3.20.04.3_arm64.deb ...
Unpacking libseccomp2:arm64 (2.4.3-1ubuntu3.20.04.3) over (2.4.3-1ubuntu1) ...
Setting up libseccomp2:arm64 (2.4.3-1ubuntu3.20.04.3) ...
(Reading database ... 14225 files and directories currently installed.)
Preparing to unpack .../systemd_245.4-4ubuntu3.2_arm64.deb ...
Unpacking systemd (245.4-4ubuntu3.2) over (245.4-4ubuntu3) ...
Preparing to unpack .../libsystemd0_245.4-4ubuntu3.2_arm64.deb ...
Unpacking libsystemd0:arm64 (245.4-4ubuntu3.2) over (245.4-4ubuntu3) ...
Setting up libsystemd0:arm64 (245.4-4ubuntu3.2) ...
(Reading database ... 14225 files and directories currently installed.)
Preparing to unpack .../libapt-pkg6.0_2.0.2ubuntu0.1_arm64.deb ...
Unpacking libapt-pkg6.0:arm64 (2.0.2ubuntu0.1) over (2.0.2) ...
Setting up libapt-pkg6.0:arm64 (2.0.2ubuntu0.1) ...
(Reading database ... 14225 files and directories currently installed.)
Preparing to unpack .../apt_2.0.2ubuntu0.1_arm64.deb ...
Unpacking apt (2.0.2ubuntu0.1) over (2.0.2) ...
Setting up apt (2.0.2ubuntu0.1) ...
/usr/sbin/policy-rc.d returned 101, not running 'restart apt-daily-upgrade.timer apt-daily.timer'
(Reading database ... 14225 files and directories currently installed.)
Preparing to unpack .../libpam-modules-bin_1.3.1-5ubuntu4.1_arm64.deb ...
Unpacking libpam-modules-bin (1.3.1-5ubuntu4.1) over (1.3.1-5ubuntu4) ...
Setting up libpam-modules-bin (1.3.1-5ubuntu4.1) ...
(Reading database ... 14225 files and directories currently installed.)
Preparing to unpack .../libpam-modules_1.3.1-5ubuntu4.1_arm64.deb ...
Unpacking libpam-modules:arm64 (1.3.1-5ubuntu4.1) over (1.3.1-5ubuntu4) ...
Setting up libpam-modules:arm64 (1.3.1-5ubuntu4.1) ...
(Reading database ... 14225 files and directories currently installed.)
Preparing to unpack .../libpam-runtime_1.3.1-5ubuntu4.1_all.deb ...
Unpacking libpam-runtime (1.3.1-5ubuntu4.1) over (1.3.1-5ubuntu4) ...
Setting up libpam-runtime (1.3.1-5ubuntu4.1) ...
(Reading database ... 14225 files and directories currently installed.)
Preparing to unpack .../passwd_1%3a4.8.1-1ubuntu5.20.04_arm64.deb ...
Unpacking passwd (1:4.8.1-1ubuntu5.20.04) over (1:4.8.1-1ubuntu5) ...
Setting up passwd (1:4.8.1-1ubuntu5.20.04) ...
(Reading database ... 14225 files and directories currently installed.)
Preparing to unpack .../0-ca-certificates_20190110ubuntu1.1_all.deb ...
Unpacking ca-certificates (20190110ubuntu1.1) over (20190110ubuntu1) ...
Preparing to unpack .../1-libjson-c4_0.13.1+dfsg-7ubuntu0.3_arm64.deb ...
Unpacking libjson-c4:arm64 (0.13.1+dfsg-7ubuntu0.3) over (0.13.1+dfsg-7) ...
Preparing to unpack .../2-libsqlite3-0_3.31.1-4ubuntu0.2_arm64.deb ...
Unpacking libsqlite3-0:arm64 (3.31.1-4ubuntu0.2) over (3.31.1-4) ...
Preparing to unpack .../3-tzdata_2020a-0ubuntu0.20.04_all.deb ...
Unpacking tzdata (2020a-0ubuntu0.20.04) over (2019c-3ubuntu1) ...
Preparing to unpack .../4-xz-utils_5.2.4-1ubuntu1_arm64.deb ...
Unpacking xz-utils (5.2.4-1ubuntu1) over (5.2.4-1) ...
Preparing to unpack .../5-linux-libc-dev_5.4.0-47.51_arm64.deb ...
Unpacking linux-libc-dev:arm64 (5.4.0-47.51) over (5.4.0-26.30) ...
Setting up libapparmor1:arm64 (2.13.3-7ubuntu5.1) ...
Setting up libsqlite3-0:arm64 (3.31.1-4ubuntu0.2) ...
Setting up linux-libc-dev:arm64 (5.4.0-47.51) ...
Setting up tzdata (2020a-0ubuntu0.20.04) ...

Current default time zone: 'Etc/UTC'
Local time is now:      Fri Sep 11 20:38:57 UTC 2020.
Universal Time is now:  Fri Sep 11 20:38:57 UTC 2020.
Run 'dpkg-reconfigure tzdata' if you wish to change it.

Setting up ca-certificates (20190110ubuntu1.1) ...
Updating certificates in /etc/ssl/certs...
0 added, 1 removed; done.
Setting up xz-utils (5.2.4-1ubuntu1) ...
Setting up libjson-c4:arm64 (0.13.1+dfsg-7ubuntu0.3) ...
Setting up systemd-timesyncd (245.4-4ubuntu3.2) ...
/usr/sbin/policy-rc.d returned 101, not running 'restart systemd-timesyncd.service'
Setting up systemd (245.4-4ubuntu3.2) ...
Setting up systemd-sysv (245.4-4ubuntu3.2) ...
Processing triggers for libc-bin (2.31-0ubuntu9) ...
Processing triggers for ca-certificates (20190110ubuntu1.1) ...
Updating certificates in /etc/ssl/certs...
0 added, 0 removed; done.
Running hooks in /etc/ca-certificates/update.d...
done.
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following NEW packages will be installed:
  apt-transport-https
0 upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
Need to get 1708 B of archives.
After this operation, 160 kB of additional disk space will be used.
Get:1 http://ports.ubuntu.com/ubuntu-ports focal-security/universe arm64 apt-transport-https all 2.0.2ubuntu0.1 [1708 B]
Fetched 1708 B in 0s (34.9 kB/s)        
debconf: delaying package configuration, since apt-utils is not installed
Selecting previously unselected package apt-transport-https.
(Reading database ... 14227 files and directories currently installed.)
Preparing to unpack .../apt-transport-https_2.0.2ubuntu0.1_all.deb ...
Unpacking apt-transport-https (2.0.2ubuntu0.1) ...
Setting up apt-transport-https (2.0.2ubuntu0.1) ...
Waiting for network to be ready...
2020-09-11T20:39:19Z INFO Waiting for automatic snapd restart...
snapd 2.45.3.1 from Canonical✓ installed
core20 20 from Canonical✓ installed
core18 20200724 from Canonical✓ installed
"core18" switched to the "latest/stable" channel

snapcraft 4.3 from Canonical✓ installed
"snapcraft" switched to the "latest/candidate" channel

*EXPERIMENTAL* extensions enabled.
sudo: unable to resolve host ubuntu: Temporary failure in name resolution
Hit:1 http://ports.ubuntu.com/ubuntu-ports focal-security InRelease
Hit:2 http://ports.ubuntu.com/ubuntu-ports focal InRelease
Hit:3 http://ports.ubuntu.com/ubuntu-ports focal-updates InRelease
Reading package lists... Done
Could not find a required package in 'build-packages': python3-colcon-common-extensions
Run the same command again with --debug to shell into the environment if you wish to introspect this failure.

In your case, it seems you are not using the extension that sets up all the required repositories.

2 Likes

Thank you for the quick reply! I found the problem: I was missing the extensions: [ros2-foxy] in the apps section.