Issues after install Snapd on Fedora 30


#1

Hi everyone. I did a clean installation of Fedora 30. After run dnf update -y, I tried to install Snapd and Spotify, but after that, Fedora started to have many problems. I installed Fedora 3 times today, and I saw when I installed snapd and reboot system, Fedora started to fail. First, the keyboard language changes to another one (I was configured in Spanish(Latin American), and after reboot it was in English). And Settings in Fedora can’t be accessible, specially the Energy Settings. And when I try to run su -, Terminal begin to run slowly. Anyone have the same issue?


#2

Sounds like https://bugzilla.redhat.com/show_bug.cgi?id=1716397


#3

Also: https://bugzilla.redhat.com/show_bug.cgi?id=1708991

We’ve landed the fix to master a couple of hours ago and now it’s waiting for 2.39.2 release. Hopefully, the updated package should be available soon.


#4

Yes!. it’s like those bugs. I’ll try to update package when it come available, and check if issue is solved. Thanks a lot buddies!


#5

Fedora 30 update is proposed with fix backported: https://bodhi.fedoraproject.org/updates/FEDORA-2019-3c4eec8250


#6

Also https://bugzilla.redhat.com/show_bug.cgi?id=1717358

As a temporary broad workaround, you can disable SELinux:

  1. As root, edit /etc/selinux/config
  2. set SELINUX=permissive
  3. Reboot your machine

Do not forget to set it back once the issue has been resolved. For a better workaround, see the BZs, there’s some good info in them.