Issue with old packages

I have been trying to build a snap for Tube-Converter But when I try to install meson_deps, It says

:: C linker for the host machine: cc ld.bfd 2.38                                  
:: C++ compiler for the host machine: c++ (gcc 11.2.0 "c++ (Ubuntu 11.2.0-19ubuntu1) 11.2.0")                                                                        
:: C++ linker for the host machine: c++ ld.bfd 2.38                               
:: Host machine cpu family: x86_64                                                
:: Host machine cpu: x86_64                                                       
:: Run-time dependency threads found: YES                                         
:: Found pkg-config: /usr/bin/pkg-config (0.29.2)                                 
:: Dependency gtk4 found: NO found 4.6.6 but need: '>= 4.8.0'                     
:: Found CMake: /usr/bin/cmake (3.22.1)                                           
:: Run-time dependency gtk4 found: NO (tried cmake)                               
:: ../src/ ERROR: Invalid version of dependency, need 'gtk4' ['>= 4.8.0'] found '4.6.6'.                                                             
:: A full log can be found at /root/parts/tube-converter/build/meson-logs/meson-log.txt                                                                              
Failed to run the build script for part 'tube-converter'.                         
Failed to execute pack in instance.  

It also needs the latest version of meson, which is not available in Core22. What should be done in these cases? Apparently this is same for almost a lot of libadwaita apps

If the dependencies are not available, or not the required version, in either any of the extensions (e.g. the gnome extension, which provides some updated libraries via its platform snap that your snap will link to when you use the extension), or the base Ubuntu release’s available Debian packages, then you will need to build and install the dependencies yourself at the required versions.

How should I check, if the gnome extension have it or not?