Issue with getting packages in stage-packages portion of snapping

I will first state I am not particularly experienced with building snaps so I might just be doing something completely wrong. So I have been working on an app and have used the snapcraft.yaml provided below. On my latest version suddenly none of the packages could be pulled resulting in an error:

Setting target machine to 'arm64'
Get:1 libnorm1_1.5.8+dfsg2-2build1_arm64.deb [262 kB]                                                                                                                  
Err libnorm1_1.5.8+dfsg2-2build1_arm64.deb                                                                                                                             
  File not found - /home/boschrexroth/./.cache/snapcraft/download/libnorm1_1.5.8+dfsg2-2build1_arm64.deb (2: No such file or directory)                                
Fetched 0 B in 0s (0 B/s)                                                                                                                                              
Package fetch error: The item '/home/boschrexroth/.cache/snapcraft/download/libnorm1_1.5.8+dfsg2-2build1_arm64.deb' could not be fetched: File not found - /home/boschrexroth/./.cache/snapcraft/download/libnorm1_1.5.8+dfsg2-2build1_arm64.deb (2: No such file or directory)

so looking at this I checked and indeed it would not pull that package, if I comment out that package it will have the same error on the next one and so on. I have tried doing a bunch of different things to try and figure out why this suddenly stopped working. I am at a complete loss at this point, so I need some help either doing this a better way or fixing the issue so I can actually build.

I have checked and all packages can be pulled manually I even tried setting it up to copy the .deb packages to that location first but the download folder gets wiped before the stage-package portion runs.

also I did a whole new VM and still no luck.

name: cmc-connect
version: '0.6.01'
summary: CMC-Connect app
description: |
  IoT System with web application @:7073 for adjusting configurations
confinement: strict 
#confinement: devmode 
#icon: assets/icons/ICONHERE.png
grade: stable  # must be 'stable' to release into candidate/stable channels
base: core20
type: app

    command: cmc-connect
    plugs: [network, network-status, network-bind, process-control]
    daemon: simple
    restart-condition: always
      ASPNETCORE_URLS: http://localhost:7073
      restart-delay: 10s
    plugin: dump
    source: ./publish/${SNAPCRAFT_TARGET_ARCH}
    - libnorm1
    - libpgm-5.2-0
    - libsodium23
    - libzmq5
    - libicu66

# describes which interface slots are supported by defining the plugs
    interface: content
    content: datalayer
    target: $SNAP_DATA/.datalayer 

Did randomly get this work one time time on the amd64 arch after trying to force each and every step (Manually doing each step). But the fact that apt-get download libnorm1:arm64 libpgm-5.2-0:arm64 libsodium23:arm64 libzmq5:arm64 libicu66:arm64 works perfectly but the app can both not pull the package AND fails to provide any hint as to why it either failed to data is a really big issue. note if you remove stage-packages: - libnorm1 - libpgm-5.2-0 - libsodium23 - libzmq5 - libicu66 then it will pull up a warning saying you should add it so that is following the recommendations. I really need some help here.