Issue starting Slack snap (cannot update snap namespace)

Hello there !

I just shutdown my laptop this noon and on restart, I was unable to launch Slack app. I tried to reinstall and switch to beta, still same issue.

Starting from command-line I have the following error:

cannot update snap namespace: cannot expand mount entry (none $HOME/.config/autostart none x-snapd.kind=ensure-dir,x-snapd.must-exist-dir=$HOME 0 0): cannot use invalid home directory "/home/logan": permission denied
snap-update-ns failed with code 1

I’m using Ubuntu (uname -a):

Linux my-computer-name 6.5.0-28-generic #29~22.04.1-Ubuntu SMP PREEMPT_DYNAMIC Thu Apr  4 14:39:20 UTC 2 x86_64 x86_64 x86_64 GNU/Linux

I think this may be fixed in snapd 2.63 which is now in beta. Try snap refresh --beta snapd and please report back whether slack now starts correctly or not.

1 Like

Nice it does the job. Thank you very much.

1 Like

Worked for me too on

XXXXX 5.15.0-105-generic #115~20.04.1-Ubuntu SMP Mon Apr 15 17:33:04 UTC 2024 x86_64 x86_64 x86_64 GNU/Linux

This didn’t work for me directly because I didn’t have snapd installed via snap. So I first had to install snapd, then I could switch the beta channel. And then it worked.

IMHO, this is critical enough that it should be backported to the current stable version or released quickly. It seems to effect several snaps and especially business oriented ones which made for a more stressful Monday morning.