Is it possible to totally remove an old release?

We have an app that has only ever been amd64. A month or two ago I was working on trying to make it work for arm64 as well, and created a universal build, which I uploaded to our edge channel. Unfortunately, that didn’t work as well as I had hoped and reverted our build to amd64-only.

However, now, our snapstore public display page claims that our app works on Raspberry Pi. It doesn’t. It never has. There has only ever been one build – in the edge channel – that even claimed to work on Raspberry Pi, and it didn’t really. But, when I click on the Raspberry Pi icon on our public page and see the install instructions, there is no mention of using the edge channel at all.

So, the real problem from my perspective is the store’s logic. It is effectively automatically advertising a stable Raspberry Pi version of my app that has never, ever existed. I’d recommend no icons at all for builds not in the stable channel.

But, if whoever is in charge of making decisions about how the store works decides the Raspberry Pi icon should remain, but the install instructions for Raspberry Pi should point the user to the edge channel, then I still have another problem that I need to fix… how do I totally remove that universal build (which never worked) from the edge channel? How do I permanently delete an old release?

I saw this suggestion:

But I don’t like the idea of turning off the entire edge channel. I still want an edge channel. We use it regularly. Not to mention that I’m not convinced that that would successfully remove the Raspberry Pi icon from my store page anyway.

So, is there some other way of getting rid of an old release?

well, this is typically only closed for a minute or so … you close it, save, then publish amd64 only back to it again, save (which opens it again for amd64 only) … and done …


In my experience (and that of others) that doesn’t work completely:

well, i can only speak from my experience, but then, i also only exclusively use the web UI and from github to manage this stuff (i.e. i have never uploaded via cmdline with snapcraft itself) … perhaps that makes a difference …

The suggestion @ogra made worked perfectly for me. Thanks!

1 Like