Installing VLC - Warning: flag --classic ignored for strictly confined snap vlc

Linux novice here.

I’m trying to get VLC to work on my Ubuntu 18.04 Server with an xfce (xubuntu) GUI. The installation commands I used:

sudo apt-get install snapd snapd-xdg-open
snap install vlc --classic
Warning: flag --classic ignored for strictly confined snap vlc

I can’t open any files with VLC on my storage drives, which are 10 TB (nominal) and 1 TB (nominal) ZFS mirror arrays.

make sure they are monted under /mnt or /media and run:

sudo snap connect vlc:removable-media

that should be enough to give you access…

EDIT: note that a bind mount will do if you do not want to move them around from a different place in the filesystem

The warning is not relevant to the problem you are seeing unless you used --classic to try to turn off the confinement? In that case I think --devmode is the flag to use.

1 Like

note that --devmode disables automatic updates for the app (while it turns off bits of confinement, it is really what it says, a developer mode (it will also produce a lot of log output))…

Excellent! With the help of this great explanation of bind
I used your command and it works.

This was a problem for over a year - once I found the right place to ask the question, it was solved very quickly. Thanks, all!

Is this command persistent?

yup, interface connections are a one-time thing after fresh install of a snap. they persist for the lifetime the package is installed (unless you call snap disconnect ... on them).

Thank you. Thanks again!