Installing snap on CentOS 7.6 doesn't work


#1

I take this installation: Installing snap on CentOS

It doesn’t work for me.

After I use this installation I get this mistake/error:

snap install hello-world
error: system does not fully support snapd: cannot mount squashfs image using “squashfs”: mount:
/tmp/sanity-squashfs-831006529: failed to setup loop device: Datei oder Verzeichnis nicht
gefunden

Here the version of my System

➜  ~ snap version
snap    2.38-1.el7
snapd   2.38-1.el7
series  16
centos  7
kernel  3.10.0-042stab132.1
➜  ~ uname -r
3.10.0-042stab132.1
➜  ~ cat /etc/centos-release
CentOS Linux release 7.6.1810 (Core)`Preformatted text`

and I use it on Plesk:

Plesk Onyx v17.8.11_build1708180301.19 os_CentOS 7

I tried it with installing copr, but same mistake:

sudo yum install yum-plugin-copr
sudo yum copr enable ngompa/snapcore-el7

I tested the installation with this command too:

$ sudo yum --enablerepo=epel-testing install snapd

I get an other Version of snap but same error message.

➜  ~ snap version
snap    2.39-1.el7
snapd   2.39-1.el7
series  16
centos  7
kernel  3.10.0-042stab132.1

reboot doesn’t help

Can Someone help ?


#2

Does the kernel support squashfs? Try running grep squashfs /proc/filesystems, is anything printed?


#3

no nothing printed if I try

~ grep squashfs /proc/filesystems

#4

Perhaps your kernel does not support squashfs. The kernel version I see on CentOS 7.6 is 3.10.0-957.12.1.el7.x86_64. You’re clearly running a different kernel.
Try this:

$ touch a
$ mksquashfs a foo.squashfs
$ sudo mount $PWD/foo.squashfs /mnt

Does the mount work?