Installing or upgrading snap wakes up *some* of my HDD (and prevents further autosleep)

I use Ubuntu 23.04, snapd 2.60.3

I have 2 WD HDD :

  • Drive A : it has a btrfs partition, usually un-mounted (I mount it only when I need it). Thanks to udisks settings, it autosleeps after 7min of inactivity
  • Drive B : it has a LUKS container (and a btrfs partition inside), usually locked. (I only unlock + mount it when needed). Thanks to udisks settings, it autosleeps after 7min30 of inactivity

With both HDD locked / unmounted and “sleeping”, whenever I install or upgrade a snap, for instance :
$ snap install newsboat

Drive B wakes up and cannot autosleep anymore. (drive A stays asleep)

Logs don’t seem to have anything interesting :

Thanks for your help ! This problem is quite annoying because this HDD is noisy and I don’t like that it stays “on” and hot for nothing.

Edit : more details, /etc/crypttab for drive B :

luks-xxxxx /dev/disk/by-uuid/xxxx none luks,noauto,nofail

(I also tried without referencing this drive B in crypttab and letting Ubuntu use default settings to handle it. I have the same result, snapd seems to wake up this drive)

Hi Amador,

Would you please reproduce this, and capture the dmesg log over the wakeup and confirm the mount state of your partitions after?

What else is happening is B used for? Would you please share lsblk <drive>