Installed Snap apps are not visible in Debian

Hello everyone!

I am a beginner when it comes to using Linux type OS. So my apologies when I am using a beginner/noob approach. I have recently reinstalled Debian 11 (Bullseye). After reinstalling the OS I installed snapd again.

After installing snapd I installed several packages but none of them are visible in de desktop environment. I have no clue were to look to find out what went wrong. Snapd confirms that they are installed but none of them show up in the desktop / software / synaptic.

I read multiple topics on this forum but none of them seems to match my specific problem. In the previous install of Debian 11 I did not have this problem. :frowning:

Does anyone have a tip/hint/advice on how to solve this (beginner/noob) problem?

Greetings from Eli!

did you log out after installing snapd ? the variables that make your desktop find the applications are being set at login time so you need to log out and back in after installing snapd to make this change take effect …

Yes off course. I saw this advice in the replies on similar topics and tried it. :slight_smile: But nothing changed. I also rebooted the OS.

what desktop environment are you using ? perhaps there are bits missing in your session or the graphical login manager ?

XCFE. I also looked in the GNOME desktop environment but there they are not visible either.

check the following variables:

$ env |grep XDG_DATA_DIRS
$ env |grep PATH

both of them should have snap related bits at the end of the output …

It seems they do not have the snap related bits. Below you can see the results of several commands. Some of them where used in other topics on this forum.

eli@ThinClient:~$ snap version snap 2.57.2 snapd 2.57.2 series 16 debian 11 kernel 5.10.0-19-amd64

eli@ThinClient:~$ echo $XDG_DATA_DIRS /usr/share/xfce4:/usr/local/share/:/usr/share/:/usr/share

eli@ThinClient:~$ systemctl --user show-environment|grep 'XDG_DATA_DIRS=' XDG_DATA_DIRS=/usr/share/xfce4:/usr/local/share/:/usr/share/

eli@ThinClient:~$ env |grep XDG_DATA_DIRS XDG_DATA_DIRS=/usr/share/xfce4:/usr/local/share/:/usr/share/:/usr/share

eli@ThinClient:~$ env |grep PATH XDG_SESSION_PATH=/org/freedesktop/DisplayManager/Session2 XDG_SEAT_PATH=/org/freedesktop/DisplayManager/Seat0 PATH=/usr/local/bin:/usr/bin:/bin:/usr/local/games:/usr/games

would it be wise to deinstall snapd and try reinstalling it? Probably I should first deinstall all the installed packages?

i do not think re-installing will change anything …

snapd ships: /usr/lib/environment.d/990-snapd.conf which should be read by systemd’s environment generators during boot to set these variables globally …

along it also ships:

/etc/X11/Xsession.d/65snappy and /etc/profile.d/ to do the same in legacy setups … i assume all these files exist on your system ?

65snappy is not there. The other 2 (990-snapd-conf & are present.

is you setup in any way special or is this a standard local desktop installation with no tweaks or modifications ?

It is a bit special.

It is a HP 620 Thinclient. At first I used the standard 16GB harddisk (MSATA, connected to SATA-0) with a AMD64 version on it. Because I ran out of disk space I bought a 128GB harddisk (M2.SATA, connected to SATA-1). At first I accidentally installed the i386 version of Debian on the 128GB disk.

After I found out I installed the the AMD64 version. But then I was no longer able to boot the AMD64 version on the 128GB disk. With help from a discord server I learned that the GRUB bootloader was installed on the wrong disk. I installed it on SATA-1 but it should have been on SATA-0.

Therefor I reinstalled the AMD64 version on the 128GB disk and choose to place the GRUB bootloader on the SATA-0 disk. So now it is a dual boot thin client with 2x AMD 64 version of Debian. One OS on the smaller disk (SATA-0) and the other OS on the larger disk (SATA-1). While guiding me through reinstalling Debian I was told to use the whole 128GB in one partition and to skip the ‘SWAP’ partition.

i rather meant if you did tweak the OS after install :slight_smile:

if you say ThinClient, do you actually run it as such ? i.e. Local Login screen but remote session or something similar ? this could surely have an impact here …

No it just a local installation. Just like any other desktop. On the smaller disk (AMD64 version) and in the previous i386 version dsnap worked just fine. After resinstalling the AMD64 version one of the first things I did was installing snapd and the snap-store (which isn’t working obviously)

After that I did the following tweaks which were advised on the link below. Only a few of them I did not install:

Is it possible that the error is caused because snapd is using the wrong core? Core20 was installed with snapd but I manually installed core18 package afterwards.