Imap2gmail: Built, failed to release

@snapcrafters: My software builds fine (based on Github integration), but it fails to release the software. The new versions do not show up on the releases tab, and I see no reason in the build log why it has failed.

https://snapcraft.io/imap2gmail/builds/1778514

I do not see any reason for the fails at the dashboard

Please advice!

Thanks,

Kristofer

+1, me to except i build on snapcraft.

Ive got one snap build stuck on “releasing” and the subsequent ones are stuck on “Built, failed to release”

both of you should check your emails, if a snap failed to release you normally get an email with a message telling you why …

alternatively you can check on:

https://dashboard.snapcraft.io/snaps/<snapname>/

that should have a summary of the upload tests for your snap …

Thanks for your reply Oliver,

unfortunately, my inbox is empty. My dashboard does not show anything either.

Thanks,

Kristofer

No email & no dashboard update :grinning_face_with_smiling_eyes:

Retried, still no releases coming through. No e-mails, and no messages in the dashboard. Noteworthy is that the build finishes quickly, and then there is a ‘wheel’ in the result column for almost an hour, before going for “Built, failed to release”.

“Built, failed to release” means there was an error while uploading to the store. This can happen if your snap is huge, for example, or if there is a problem with the store at present.

@roadmr do you know if it will be possible to add a check to status.snapcraft.io that indicates whether snap uploads are working? it seems the current status checks are all on the side of snapd talking to the store to find and install snaps, but the store has a larger surface area than that so it would be a good idea to add more statuses for the areas not currently covered.

Hi!

An upload check sounds slightly tricky because we’d have to be uploading test snaps constantly to be able to tell for sure.

The existing status reports cover general health of the services, and we do have internal alerts in case some of the internal plumbing is unhappy - which hasn’t been the case in any timeframe that correlates with @tingdahl’s reported failures :frowning: The snap is also not huge.

I suspect an authentication issue since I remember we did some dancing with revoking/reregistering the snap, so I would suggest for @tingdahl to go to the Launchpad build thingy and use the “reauthorize” button to reissue the necessary tokens.

Let me know if the above is vague and I can dig further on how to get to the “reauthorize” button :slight_smile:

  • Daniel

Disconnecting from Github, and reconnecting again worked. It now releases properly.

1 Like