I'm never asked for 2FA despite having it enabled

I just thought I’d post this here so it can be investigated if needs be, or maybe there’s a mistake I’ve made in the process.

A while ago, I’d requested to join the Launchpad 2FA testing group, this was accepted and I’d since set up 2FA in the Ubuntu SSO page that appears when in the 2FA group. Logging into Ubuntu SSO directly does not require the 2FA, but accessing Launchpad does. Snapcraft doesn’t, whether via CLI, snapcraft.io, or dashboard.snapcraft.io, and the CLI in particular is rather eager about encouraging you to set up 2FA!

Recently I’d seen another developers login flow where their CLI actually asked for an authentication code, so clearly it can be made to work. Is there likely somewhere that I’ve made a mistake in this process or am I right in assuming this might be a server side issue with Snapcraft?

To be explicit, this is definitely regarding the Ubuntu SSO side of things and not the Discourse forum software, the 2FA there works fine.


Hi there, This has to be configured explicitly if you want 2FA to be required when logging into your account.

Go to https://login.ubuntu.com/ and under “Authentication devices” tick “Always require an authentication device”, then save the changes.

  • Daniel

Thanks for the hint Daniel. It’s strange that option isn’t with the rest of the 2FA settings (it’s a category on the personal details page instead) but it’s exactly what I was looking for :slight_smile: